Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1494307

Summary: Use mariadb-connector-c-devel instead of community-mysql-devel
Product: [Fedora] Fedora Reporter: Michal Schorm <mschorm>
Component: openchangeAssignee: Milan Crha <mcrha>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: asn, gdeschner, mbarnes, mcrha, ssorce
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openchange-2.3-17.fc28 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-09-22 07:23:17 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1486480    

Description Michal Schorm 2017-09-22 01:24:40 UTC
Hello, please apply following command to the package SPECfile:

sed -i "s/community-mysql-devel/mariadb-connector-c-devel/" $(fedpkg gimmespec) ;

I've tested, that after the command ^ the package builds successfuly in KOJI, however in any case (before or after patch) it does not use the mysql / mariadb client library, which mostly indicates it does not mysql at all. Please check it and remove the Buildrequires entirely, if I'm right.


This change is currently applicable to the Rawhide (f28) only.




For more information check the tracking bugzilla.

Comment 1 Milan Crha 2017-09-22 07:23:17 UTC
Thanks for a bug report. I replaced it, rather than removed, because the removal also means to change configure.ac. Even it might not be needed, because the package omits the server part and installs only the client side, I think it's safer to bring in the build dependency than carry another patch.