Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1500027

Summary: Drop preventing bind mounts when port is specified
Product: [Fedora] Fedora Reporter: Orion Poplawski <orion>
Component: autofsAssignee: Ian Kent <ikent>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: rawhideCC: ikent, orion
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: autofs-5.1.4-5.fc26 autofs-5.1.4-5.fc27 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-02-09 11:27:32 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Orion Poplawski 2017-10-09 17:10:27 UTC
Description of problem:

Currently, automount will not to a bind mount is a port= option is specified for the map.  This hit me when trying to switch to rmda,port=20049.

This seems to be the commit where it was added:

commit 9d8afd6da0dc4e109dc282323f7ba4f9ad2e75f1
Author: Ian Kent <raven.net>
Date:   Fri Feb 16 10:45:33 2007 +0900

    - fix localhost replicated mounts not working.

But I don't know what localhost replicated mounts are.

I've got a workaround at the moment - adding the options to the map entries rather than the map options.  But this was unexpected.  I would think the newer 'nobind' option would now cover this need more explicitly.

Comment 1 Ian Kent 2017-10-09 23:53:57 UTC
(In reply to Orion Poplawski from comment #0)
> Description of problem:
> 
> Currently, automount will not to a bind mount is a port= option is specified
> for the map.  This hit me when trying to switch to rmda,port=20049.

That's a bit unclear but I think your trying to say using the port
option prevents bind mounting.

> 
> This seems to be the commit where it was added:
> 
> commit 9d8afd6da0dc4e109dc282323f7ba4f9ad2e75f1
> Author: Ian Kent <raven.net>
> Date:   Fri Feb 16 10:45:33 2007 +0900
> 
>     - fix localhost replicated mounts not working.

Sadly I didn't add a description to that patch and I can't
remember now why I did it.

> 
> But I don't know what localhost replicated mounts are.

Perhaps you know what a replicated mount is?

One where there are multiple hosts, perhaps with a priority
to force order in which they are tried.

eg.
key    host1,host2(5),hostn(1):/export/path

and any one of those could correspond to the local machine.
 
> 
> I've got a workaround at the moment - adding the options to the map entries
> rather than the map options.  But this was unexpected.  I would think the
> newer 'nobind' option would now cover this need more explicitly.

Probably not.

It might be that I needed to explicitly prevent bind mounts for
the replicated host selection to work but there may have been
more to it.

Given this a quick look at the patch implies that this would
be done for singleton mounts as well, perhaps fixing that will
be sufficient for the moment ....

I'll have a look at that if that sounds like it will help your
case.

Ian

Comment 2 Ian Kent 2017-10-11 01:00:39 UTC
(In reply to Orion Poplawski from comment #0)
> 
> I've got a workaround at the moment - adding the options to the map entries
> rather than the map options.  But this was unexpected.  I would think the
> newer 'nobind' option would now cover this need more explicitly.

That's odd, using the port option on map entries looks like
it shouldn't work but .....

I think you are right, looking at the history I think the nobind
option should be required to prevent bind mounting.

The hack of of using the port option to prevent bind mounts was
added in early version 5 development, long before the nobind
option was available.

Not only that the original name of the patch for commit 9d8afd6d
refers to "proximity-local-handling" so the port option handling
itself I think was not the main point of the change.

Mmmm .....

Comment 3 Ian Kent 2017-10-12 03:02:01 UTC
A little while ago I was planning on releasing 5.1.4 but I
never got around to commiting the patch list and doing the
release.

I'm still keen to get 5.1.4 out (including this change) but
that will take a few days.

So the question is would you like me to make this change now
and update later (hopefully next week) or would you be willing
to just wait for the update?

Comment 4 Orion Poplawski 2017-10-12 20:12:21 UTC
I'm in no hurry as I have a workaround.  And I'm actually running EL7, but figured this would be the place to get it addressed first :).

Comment 5 Fedora Update System 2017-12-19 23:39:02 UTC
autofs-5.1.4-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-21cb07e1d3

Comment 6 Fedora Update System 2017-12-19 23:44:16 UTC
autofs-5.1.4-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-593cc5120d

Comment 7 Fedora Update System 2017-12-21 20:25:13 UTC
autofs-5.1.4-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-21cb07e1d3

Comment 8 Fedora Update System 2017-12-21 21:10:38 UTC
autofs-5.1.4-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-593cc5120d

Comment 9 Fedora Update System 2017-12-22 03:21:11 UTC
autofs-5.1.4-4.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-eda74692fc

Comment 10 Fedora Update System 2017-12-22 03:21:31 UTC
autofs-5.1.4-4.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-164b3ee23a

Comment 11 Fedora Update System 2017-12-22 12:43:20 UTC
autofs-5.1.4-4.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-eda74692fc

Comment 12 Fedora Update System 2017-12-22 13:16:06 UTC
autofs-5.1.4-4.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-164b3ee23a

Comment 13 Fedora Update System 2018-02-01 07:17:45 UTC
autofs-5.1.4-5.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-eda74692fc

Comment 14 Fedora Update System 2018-02-01 07:42:05 UTC
autofs-5.1.4-5.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-164b3ee23a

Comment 15 Fedora Update System 2018-02-01 19:09:20 UTC
autofs-5.1.4-5.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-164b3ee23a

Comment 16 Fedora Update System 2018-02-01 19:30:17 UTC
autofs-5.1.4-5.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-eda74692fc

Comment 17 Fedora Update System 2018-02-09 11:27:32 UTC
autofs-5.1.4-5.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2018-02-09 16:29:33 UTC
autofs-5.1.4-5.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.