Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at

Bug 1516863

Summary: mongo-cxx-driver: Builds against compat-openssl10-devel which will be removed
Product: [Fedora] Fedora Reporter: Tomas Mraz <tmraz>
Component: mongo-cxx-driverAssignee: Patrik Novotný <panovotn>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 30CC: hhorak, hkario, panovotn, tdawson
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Fixed In Version: mongo-cxx-driver-3.3.1-1.fc30 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-09-09 08:29:31 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1383740    

Description Tomas Mraz 2017-11-23 13:01:10 UTC
The package currently depends on compat-openssl10-devel which will be removed. It needs to be ported to OpenSSL 1.1 API and built against regular openssl-devel package.

If you need help with porting the package feel free to contact me.

Comment 1 Fedora End Of Life 2018-02-20 15:21:28 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 28 development cycle.
Changing version to '28'.

Comment 3 Ben Cotton 2019-02-19 17:12:17 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 30 development cycle.
Changing version to '30.

Comment 4 Honza Horak 2019-09-09 08:29:31 UTC
Since v3.3.1, the package does not link with openssl any more, it links with libmongo instead, which in turn links with openssl 1.1.0. The version 1.1.2 that still requires compat-openssl10 is in Fedora 29, which will go EOL soon, so closing this tracker.