Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1526788

Summary: python-etcd binary packages are misnamed
Product: [Fedora] Fedora Reporter: Zbigniew JÄ™drzejewski-Szmek <zbyszek>
Component: python-etcdAssignee: Steve Milner <smilner>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: mbarnes, smilner
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-etcd-0.4.5-8.fc27 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-02-06 11:20:13 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Zbigniew Jędrzejewski-Szmek 2017-12-17 13:11:24 UTC
Description of problem:
They are called python2-python-etcd, python3-python-etc, the "-python" part in the middle should be dropped.
https://fedoraproject.org/wiki/Packaging:Naming#Python_modules

Version-Release number of selected component (if applicable):
python-etcd-0.4.5-7.fc27

Comment 1 Steve Milner 2017-12-18 15:10:50 UTC
Eek! How did that happen!

Comment 2 Steve Milner 2017-12-18 15:15:28 UTC
Confirmed. It looks like srcname was used where modname should have been used.

Comment 3 Fedora Update System 2017-12-18 17:11:54 UTC
python-etcd-0.4.5-8.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-00e65b29f3

Comment 4 Fedora Update System 2017-12-18 22:02:52 UTC
python-etcd-0.4.5-8.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-00e65b29f3

Comment 5 Fedora Update System 2018-02-06 11:20:13 UTC
python-etcd-0.4.5-8.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2018-02-06 15:26:25 UTC
python-etcd-0.4.5-8.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.