Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1531569

Summary: Botan 2.2+ (to support openssl-1.1)
Product: [Fedora] Fedora Reporter: Rex Dieter <rdieter>
Component: botanAssignee: Thomas Moschny <thomas.moschny>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: bkircher, thomas.moschny
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-03-30 13:11:55 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1487067    
Bug Blocks: 1383740    

Description Rex Dieter 2018-01-05 14:38:25 UTC
It appears that Botan versions since 2.2 (2.3.0 is the latest as of now), supports openssl-1.1

For example, I'm working to incorporate openssl-1.1 support into qca, but will probably have to disable the -botan plugin/backend until this is implemented.

Comment 1 Thomas Moschny 2018-01-13 11:35:38 UTC
See bug 1487067, there will be a botan2 package.

Comment 2 Rex Dieter 2018-01-13 15:05:50 UTC
Thanks!  I think I may even be able to help with sponsorship there, I'll take a closer look soon.

Comment 3 Ben Kircher 2018-03-06 16:46:00 UTC
Package in rawhide (https://src.fedoraproject.org/rpms/botan2).

Comment 4 Rex Dieter 2018-03-06 17:01:51 UTC
FYI, looks like botan2 hard-codes a bunch of it's own compiler/link flags, see:
src/build-data/cc/gcc.txt
(and throws away the distro default ones apparently)

Comment 5 Rex Dieter 2018-03-06 17:02:16 UTC
sorry, I'll add that to the review bug

Comment 6 Fedora Update System 2018-03-21 11:30:05 UTC
botan2-2.4.0-9.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-b2a764b252

Comment 7 Fedora Update System 2018-03-21 14:15:04 UTC
botan2-2.4.0-9.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-b2a764b252

Comment 8 Fedora Update System 2018-03-30 13:11:55 UTC
botan2-2.4.0-9.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.