Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1551215

Summary: Enhancement to foce querying on ipv4 or ipv6
Product: [Fedora] Fedora EPEL Reporter: John Fawcett <john>
Component: jwhoisAssignee: Vitezslav Crhonek <vcrhonek>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: epel7CC: john, redhat-bugzilla, vcrhonek
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: jwhois-4.0-47.el7 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-10-04 20:28:40 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
patch none

Description John Fawcett 2018-03-03 14:04:55 UTC
Created attachment 1403436 [details]
patch

Enhancement submission adding command line options -4 and -6 to force querying to an ipv4 or ipv6 address.

This can be useful for eaxmple if you have both ipv4 and ipv6 enabled but you cannot send queries to the whois server from ipv6.

Comment 2 Petr Pisar 2018-03-05 10:38:06 UTC
Thank you for the patch, but it seems to be a patch for jwhois that is not provided by RHEL-7. In RHEL-7 we have whois (without the initial `j' letter). Unfortunately RHEL-7 whois also does not offer protocol family selection.

Are you interested in enhancing whois package instead? If so, could you contact Red Hat support to escalate your request properly? We do not usually add new features into already released code. That requires an official customer request through the support team.

If you are not a customer with a RHEL subscription, please send your patch to (j)whois authors. I think they will welcome it.

Comment 3 John Fawcett 2018-03-05 20:53:16 UTC
The jwhois package is from Fedora epel. Can this be reassigned to Fedora?

Comment 4 Fedora Update System 2018-03-15 13:52:50 UTC
jwhois-4.0-46.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-4408a2a797

Comment 5 Vitezslav Crhonek 2018-03-15 13:53:25 UTC
Thanks, applied!

Comment 6 Fedora Update System 2018-03-15 15:41:01 UTC
jwhois-4.0-46.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-4408a2a797

Comment 7 Fedora Update System 2019-09-18 07:41:12 UTC
FEDORA-EPEL-2019-f0fc6f11d3 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-f0fc6f11d3

Comment 8 Fedora Update System 2019-09-19 02:38:23 UTC
jwhois-4.0-47.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-f0fc6f11d3

Comment 9 Fedora Update System 2019-10-04 20:28:40 UTC
jwhois-4.0-47.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.