Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1551668

Summary: perl-Verilog-Perl-3.448-1.fc29 FTBFS: t/35_sigparser.t crashes
Product: [Fedora] Fedora Reporter: Petr Pisar <ppisar>
Component: perl-Verilog-PerlAssignee: Jitka Plesnikova <jplesnik>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 28CC: chitlesh, jplesnik, perl-devel, releng, rosset.filipe
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
URL: https://apps.fedoraproject.org/koschei/package/perl-Verilog-Perl?collection=f29
Whiteboard:
Fixed In Version: perl-Verilog-Perl-3.452-1.fc29 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-04-27 06:11:34 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1555378    

Description Petr Pisar 2018-03-05 16:36:04 UTC
perl-Verilog-Perl-3.448-1.fc29 fails to build in F29 because a test fails:

t/35_sigparser.t ..... 
Failed 3/6 subtests 
t/36_sigmany.t ....... ok
[...]
Test Summary Report
-------------------
t/35_sigparser.t   (Wstat: 134 Tests: 3 Failed: 0)
  Non-zero wait status: 134
  Parse errors: Bad plan.  You planned 6 tests but ran 3.

Fedora 28 is affected too.

Comment 1 Jitka Plesnikova 2018-03-15 06:46:28 UTC
*** Bug 1556108 has been marked as a duplicate of this bug. ***

Comment 3 Jitka Plesnikova 2018-04-13 12:27:21 UTC
It was fixed in Verilog-Perl 3.452.

* Verilog::Language 3.452 2018-04-12
****    Fix parsing "output signed" in V2K port list, msg2540. [James Jung]
****    Fix GLIBC assertion failure, bug1299. [Filipe Rosset]

Comment 4 Fedora Update System 2018-04-13 12:43:36 UTC
perl-Verilog-Perl-3.452-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-b753e763b5

Comment 5 Fedora Update System 2018-04-15 02:25:51 UTC
perl-Verilog-Perl-3.452-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-b753e763b5

Comment 6 Fedora Update System 2018-04-27 04:02:20 UTC
perl-Verilog-Perl-3.452-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.