Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1551797

Summary: rubygem-erubi-1.10.0 is available
Product: [Fedora] Fedora Reporter: Upstream Release Monitoring <upstream-release-monitoring>
Component: rubygem-erubiAssignee: Vít Ondruch <vondruch>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: ewl+redhat, urisimchoni, vondruch
Target Milestone: ---Keywords: FutureFeature, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: rubygem-erubi-1.10.0-1.fc35 rubygem-erubi-1.10.0-1.fc34 Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-05-19 11:02:41 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Upstream Release Monitoring 2018-03-06 00:11:30 UTC
Latest upstream release: 1.7.1
Current version/release in rawhide: 1.7.0-1.fc28
URL: https://github.com/jeremyevans/erubi

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/14545/

Comment 1 Upstream Release Monitoring 2019-09-25 16:55:04 UTC
Latest upstream release: 1.9.0
Current version/release in rawhide: 1.7.0-4.fc31
URL: https://github.com/jeremyevans/erubi

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from anitya: https://release-monitoring.org/project/14545/

Comment 2 Upstream Release Monitoring 2020-11-13 22:34:34 UTC
Latest upstream release: 1.10.0
Current version/release in rawhide: 1.7.0-6.fc33
URL: https://github.com/jeremyevans/erubi

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from anitya: https://release-monitoring.org/project/14545/

Comment 3 Eric L. 2021-05-08 05:01:42 UTC
This upgrade request would become urgent as the winrm-elevated plugin for vagrant depends on erubi (~> 1.8) and the version 1.7 currently in the Fedora repos conflicts with this. This means that I can't use Vagrant for Windows VMs currently under Fedora 34, and I couldn't find any workaround for this, so this is urgent.

```
$ vagrant plugin install winrm-elevated
Installing the 'winrm-elevated' plugin. This can take a few minutes...
Vagrant failed to properly resolve required dependencies. These
errors can commonly be caused by misconfigured plugin installations
or transient network issues. The reported error is:

conflicting dependencies erubi (~> 1.8) and erubi (= 1.7.0)
  Activated erubi-1.7.0
  which does not match conflicting dependency (~> 1.8)

  Conflicting dependency chains:
    erubi (= 1.7.0), 1.7.0 activated

  versus:
    winrm-elevated (> 0), 1.1.1 activated, depends on
    winrm-fs (~> 1.0), 1.3.5 activated, depends on
    erubi (~> 1.8)
```

Comment 4 Uri Simchoni 2021-05-09 11:14:50 UTC
"me too" on the Windows VM. This is a core use case for Vagrant on Fedora - Fedora hasn't been supporting some Vagrant plugins (e.g vagrant-aws) for a while now (due to version conflicts), but it had good support for libvirt. With containers being used more and more for Linux workloads, I dare say that running Windows VMs is THE primary use case for Vagrant on Fedora.

Comment 5 Fedora Update System 2021-05-19 11:01:57 UTC
FEDORA-2021-f309b8dd99 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-f309b8dd99

Comment 6 Fedora Update System 2021-05-19 11:02:41 UTC
FEDORA-2021-f309b8dd99 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 7 Fedora Update System 2021-05-19 12:32:56 UTC
FEDORA-2021-a4e5358635 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-a4e5358635

Comment 8 Fedora Update System 2021-05-21 01:35:05 UTC
FEDORA-2021-a4e5358635 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-a4e5358635`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-a4e5358635

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2021-05-29 01:04:17 UTC
FEDORA-2021-a4e5358635 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.