Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1560091

Summary: [abrt] meson: join(): posixpath.py:78:join:TypeError: expected str, bytes or os.PathLike object, not NoneType
Product: [Fedora] Fedora Reporter: Jan-Michael Brummer <jan.brummer>
Component: mesonAssignee: Igor Gnatenko <ignatenko>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: ignatenko, sgallagh, wtaymans
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
URL: https://retrace.fedoraproject.org/faf/reports/bthash/a71c7a0c38d71e04cdc730a1acc8bcb48d6934ea
Whiteboard: abrt_hash:be8acad36bac3f848a00d3462793cefa63ad3da7;VARIANT_ID=workstation;
Fixed In Version: meson-0.46.1-1.fc28 meson-0.46.1-1.fc27 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-05-23 15:39:53 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
File: backtrace
none
File: cgroup
none
File: cpuinfo
none
File: environ
none
File: mountinfo
none
File: namespaces
none
File: open_fds none

Description Jan-Michael Brummer 2018-03-23 21:09:34 UTC
Version-Release number of selected component:
meson-0.45.1-1.fc29

Additional info:
reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 -s /usr/bin/meson introspect --tests
crash_function: join
exception_type: TypeError
executable:     /usr/bin/meson
interpreter:    python3-3.6.4-17.fc29.x86_64
kernel:         4.16.0-0.rc6.git2.1.fc29.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
posixpath.py:78:join:TypeError: expected str, bytes or os.PathLike object, not NoneType

Traceback (most recent call last):
  File "/usr/bin/meson", line 26, in <module>
    sys.exit(main())
  File "/usr/bin/meson", line 23, in main
    return mesonmain.run(sys.argv[1:], launcher)
  File "/usr/lib/python3.6/site-packages/mesonbuild/mesonmain.py", line 293, in run
    return mintro.run(remaining_args)
  File "/usr/lib/python3.6/site-packages/mesonbuild/mintro.py", line 212, in run
    coredata = cdata.load(options.builddir)
  File "/usr/lib/python3.6/site-packages/mesonbuild/coredata.py", line 344, in load
    filename = os.path.join(build_dir, 'meson-private', 'coredata.dat')
  File "/usr/lib64/python3.6/posixpath.py", line 78, in join
    a = os.fspath(a)
TypeError: expected str, bytes or os.PathLike object, not NoneType

Local variables in innermost frame:
p: ('meson-private', 'coredata.dat')
a: None

Potential duplicate: bug 1558569

Comment 1 Jan-Michael Brummer 2018-03-23 21:09:40 UTC
Created attachment 1412293 [details]
File: backtrace

Comment 2 Jan-Michael Brummer 2018-03-23 21:09:41 UTC
Created attachment 1412294 [details]
File: cgroup

Comment 3 Jan-Michael Brummer 2018-03-23 21:09:42 UTC
Created attachment 1412295 [details]
File: cpuinfo

Comment 4 Jan-Michael Brummer 2018-03-23 21:09:44 UTC
Created attachment 1412296 [details]
File: environ

Comment 5 Jan-Michael Brummer 2018-03-23 21:09:45 UTC
Created attachment 1412297 [details]
File: mountinfo

Comment 6 Jan-Michael Brummer 2018-03-23 21:09:47 UTC
Created attachment 1412298 [details]
File: namespaces

Comment 7 Jan-Michael Brummer 2018-03-23 21:09:48 UTC
Created attachment 1412299 [details]
File: open_fds

Comment 8 Igor Gnatenko 2018-04-24 18:47:56 UTC
*** Bug 1558569 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2018-04-24 18:49:06 UTC
meson-0.46.0-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-449b417a22

Comment 10 Fedora Update System 2018-04-24 18:49:20 UTC
meson-0.46.0-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-0584344039

Comment 11 Fedora Update System 2018-04-25 19:42:52 UTC
meson-0.46.0-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-449b417a22

Comment 12 Fedora Update System 2018-04-26 04:51:44 UTC
meson-0.46.0-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-0584344039

Comment 13 Fedora Update System 2018-05-17 08:25:17 UTC
meson-0.46.1-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-f6387fdc8c

Comment 14 Fedora Update System 2018-05-17 08:25:29 UTC
meson-0.46.1-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-06bae06ef4

Comment 15 Fedora Update System 2018-05-17 13:33:40 UTC
meson-0.46.1-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-06bae06ef4

Comment 16 Fedora Update System 2018-05-17 15:27:30 UTC
meson-0.46.1-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-f6387fdc8c

Comment 17 Fedora Update System 2018-05-23 15:39:53 UTC
meson-0.46.1-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2018-05-25 15:44:41 UTC
meson-0.46.1-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.