Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1564533

Summary: f28-extras.xml in backgrounds-extras package has a missing photo name & an incorrect name
Product: [Fedora] Fedora Reporter: Hedayat Vatankhah <hedayatv>
Component: f28-backgroundsAssignee: Luya Tshimbalanga <luya_tfz>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 28CC: luya, luya_tfz
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: f28-backgrounds-28.1.2-1.fc28 f28-backgrounds-28.1.3-1.fc28 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-04-19 22:07:59 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Hedayat Vatankhah 2018-04-06 14:40:16 UTC
Description of problem:
/usr/share/backgrounds/f28/extras/cresent-moon.jpg doesn't exist in the package, but is referenced in f28-extras.xml

There is an entry for:
/usr/share/backgrounds/f28/extras/alley-in-sarsina.CC-BY-SA 4.0
which should have the correct file name.


Version-Release number of selected component (if applicable):
f28-backgrounds-extras-base-28.1.0-1.fc28.noarch

Comment 1 Fedora Update System 2018-04-11 04:14:13 UTC
f28-backgrounds-28.1.2-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-2259fd8963

Comment 2 Fedora Update System 2018-04-11 22:58:05 UTC
f28-backgrounds-28.1.2-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-2259fd8963

Comment 3 Fedora Update System 2018-04-15 02:38:12 UTC
f28-backgrounds-28.1.2-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 4 Hedayat Vatankhah 2018-04-16 10:52:33 UTC
Bug in name alley-in-sarsina.CC-BY-SA 4.0 still exists in f28-extras.xml, while the image is named alley-in-sarsina.png

cresent-moon.jpg is referenced in f28-extras.xml, but the image is a PNG image

Another problem also exists: f28-extras.xml contains 2 entries for dark-blue: one for dark-blue.jpg and another for dark-blue.png. Probably the reference to dark-blue.jpg should be removed, since there is no such file (and the entry is duplicated anyway).

Comment 5 Fedora Update System 2018-04-17 04:53:42 UTC
f28-backgrounds-28.1.3-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-292ca32b20

Comment 6 Hedayat Vatankhah 2018-04-17 11:05:17 UTC
If the package contains this xml:
https://github.com/fedoradesign/backgrounds/blob/v28.1.3/extras/f28-extras.xml

I don't see any of the problems I mentioned are fixed. It seems exactly the same as the one in 28.1.2.

Comment 7 Luya Tshimbalanga 2018-04-17 14:51:35 UTC
I just updated the github to reflect the change already included in 28.1.3 tarball. Please test https://bodhi.fedoraproject.org/updates/FEDORA-2018-292ca32b20 and vefity the fix works. Thanks.

Comment 8 Fedora Update System 2018-04-17 18:08:58 UTC
f28-backgrounds-28.1.3-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-292ca32b20

Comment 9 Hedayat Vatankhah 2018-04-18 12:08:31 UTC
Fixed, thanks :)

Comment 10 Fedora Update System 2018-04-19 22:07:59 UTC
f28-backgrounds-28.1.3-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.