Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1567727

Summary: f28-backgrounds-extras filename mismatches
Product: [Fedora] Fedora Reporter: Yaakov Selkowitz <yselkowi>
Component: f28-backgroundsAssignee: Luya Tshimbalanga <luya_tfz>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: 28CC: fzatlouk, luya_tfz, yselkowi
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedFreezeException
Fixed In Version: f28-backgrounds-28.1.3-1.fc28 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-04-19 22:07:55 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1469207    

Description Yaakov Selkowitz 2018-04-16 05:51:10 UTC
There are filename mismatches between the .desktop and .jpg files of two of the F28 supplemental desktop backgrounds, morning-at-étang-de-berre and stora-hornsjön; the .jpg includes the accents and the .desktop files (for KDE) and the XML files (for GNOME and MATE) do not:

https://github.com/fedoradesign/backgrounds/tree/master/extras
https://github.com/fedoradesign/backgrounds/blob/master/extras/gnome-backgrounds-f28-extras.xml
https://github.com/fedoradesign/backgrounds/blob/master/extras/mate-backgrounds-f28-extras.xml

This causes the .desktop files not to be installed, as can be seen in the build.log (look for "cannot stat"):

https://kojipkgs.fedoraproject.org//packages/f28-backgrounds/28.1.2/1.fc28/data/logs/noarch/build.log

The result of all these mismatches is that these two backgrounds are not made available in any of the three affected desktops.

Comment 1 Fedora Blocker Bugs Application 2018-04-16 05:58:46 UTC
Proposed as a Freeze Exception for 28-final by Fedora user yselkowitz using the blocker tracking app because:

 Two of the supplemental backgrounds/wallpapers are not selectable through the usual means on the GNOME, KDE, and MATE desktops.  IIUC supplemental artwork does not block the release, but perhaps a freeze exception may be warranted here.

Comment 2 Fedora Update System 2018-04-17 04:53:37 UTC
f28-backgrounds-28.1.3-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-292ca32b20

Comment 3 František Zatloukal 2018-04-17 09:08:14 UTC
Discussed during the 2018-04-16 blocker review meeting: [1]

The decision to classify this bug as an AcceptedFreezeException was made:

"This affects use of the affected backgrounds on at least the MATE and probably the Cinnamon live images, so it's worth fixing in the frozen package set"

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-04-16/f28-blocker-review.2018-04-16-16.00.log.txt

Comment 4 Fedora Update System 2018-04-17 18:08:56 UTC
f28-backgrounds-28.1.3-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-292ca32b20

Comment 5 Fedora Update System 2018-04-19 22:07:55 UTC
f28-backgrounds-28.1.3-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.