Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1583651

Summary: gerbera is not functional
Product: [Fedora] Fedora Reporter: Dennis Gilmore <dennis>
Component: gerberaAssignee: Gwyn Ciesla <gwync>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 29CC: dgilmore, gwync
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: gerbera-1.2.0-2.fc29 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-11-01 15:06:35 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Dennis Gilmore 2018-05-29 12:25:01 UTC
Description of problem:
There seems to be a few problems with gerbera. One is that it is opening up a ipv6 socket, but is binding to the link local and not the global routable IP address.

More importantly the web interface does not load correctly, according to the debug data provided by firefox it is because of a missing .map files

Source map error: TypeError: NetworkError when attempting to fetch resource.
Resource URL: http://172.16.46.153:50500/vendor/bootstrap/js/bootstrap.min.js
Source Map URL: bootstrap.min.js.map[Learn More]
Source map error: TypeError: NetworkError when attempting to fetch resource.
Resource URL: http://172.16.46.153:50500/vendor/popper/popper.js
Source Map URL: popper.js.map[Learn More]
Source map error: TypeError: NetworkError when attempting to fetch resource.
Resource URL: http://172.16.46.153:50500/vendor/bootstrap/css/bootstrap.css
Source Map URL: bootstrap.css.map[Learn More]
Source map error: TypeError: NetworkError when attempting to fetch resource.
Resource URL: http://172.16.46.153:50500/vendor/bootstrap/css/bootstrap-grid.css
Source Map URL: bootstrap-grid.css.map[Learn More]

Comment 1 Jan Kurik 2018-08-14 10:00:31 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 2 Dennis Gilmore 2018-10-06 13:52:09 UTC
This still exists in 1.2.0

Comment 3 Fedora Update System 2018-10-23 20:08:00 UTC
gerbera-1.2.0-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-38681879bc

Comment 4 Fedora Update System 2018-10-24 15:40:50 UTC
gerbera-1.2.0-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-38681879bc

Comment 5 Dennis Gilmore 2018-10-29 14:43:11 UTC
this still exists

Comment 6 Fedora Update System 2018-11-01 15:06:35 UTC
gerbera-1.2.0-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.