Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1592146

Summary: qt5-qtbase-devel requires python2
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: qt5-qtbaseAssignee: Than Ngo <than>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: jgrulich, jreznik, rdieter, than
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-23 09:34:54 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1285816    

Description Miro Hrončok 2018-06-17 21:16:30 UTC
qt5-qtbase-devel requires /usr/bin/python2 due to /usr/lib64/qt5/mkspecs/features/uikit/devices.py with Python 2 shebang.

The script seems python3 compatible (it even has a from __future__ import print_function line). Could you please change the shebang to be /usr/bin/python3 instead? (Or drop the file if it's not needed.)

Version-Release number of selected component (if applicable): qt5-qtbase-devel-0:5.11.0-2.fc29


Steps to Reproduce:
1. $ dnf repoquery --requires qt5-qtbase-devel | grep python

Actual results: /usr/bin/python2


Expected results: /usr/bin/python3 (or nothing)

Comment 1 Than Ngo 2018-06-23 09:34:54 UTC
it's fixed in qt5-qtbase-5.11.1-2.fc29

Comment 2 Miro Hrončok 2018-06-23 11:33:21 UTC
Thank you.