Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1598524

Summary: glibc32 Build Adjustments
Product: [Fedora] Fedora Reporter: Ben Cotton <bcotton>
Component: Changes TrackingAssignee: Florian Weimer <fweimer>
Status: CLOSED RAWHIDE QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 38CC: fweimer, riehecky
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: glibc-2.39.9000-7.fc41 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2023-02-22 19:30:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 2256942    
Bug Blocks:    

Description Ben Cotton 2018-07-05 17:55:13 UTC
This is a tracking bug for Change: glibc 32 Build Adjustments
For more details, see: https://fedoraproject.org/wiki/Changes/glibc32_Build_Adjustments

The glibc32 package is a special package used by gcc and a few other packages to work around the lack of RPM multilib repository support in Koji. It is difficult to maintain, and the current approach raises questions regarding (L)GPL compliance.

Comment 1 Jan Kurik 2018-08-14 11:05:34 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 2 Ben Cotton 2018-08-14 13:12:53 UTC
According to the Fedora 29 schedule[1], today is the deadline for changes to be in a testable state. If your change is ready to be tested, please set the status to ON_QA. A list of incomplete changes will be sent to FESCo tomorrow for evaluation. If you know your change will not be ready for Fedora 29, you can set the version to rawhide and notify bcotton.

[1] https://fedoraproject.org/wiki/Releases/29/Schedule

Comment 3 Florian Weimer 2018-08-14 14:12:02 UTC
We have to reschedule this to Fedora 30.  Fedora releng did not implement their part so far.

Comment 4 Ben Cotton 2019-02-19 17:12:16 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 30 development cycle.
Changing version to '30.

Comment 5 Ben Cotton 2019-03-05 21:49:58 UTC
We have reached the Code Complete (100%) milestone in the Fedora 30 development cycle. At this point, all Changes should be fully code complete and ready for testing during the beta freeze. If your Change has reached this milestone, please set the status to ON_QA. If it has not, this Change will be submitted to FESCo to evaluate the contigency plan and decide if the Change will continue in the Fedora 30 cycle.

Comment 6 Ben Cotton 2019-03-11 15:47:45 UTC
Deferred to F31 by FESCo

Comment 7 Florian Weimer 2019-04-09 07:17:26 UTC
We are still investigating the best way to deal with the glibc32 situation.  It may be possible to remove the package altogether.

Comment 8 Ben Cotton 2019-08-13 16:49:37 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 9 Ben Cotton 2019-08-14 17:56:13 UTC
We have reached the 'Code Complete (testable)' milestone in the Fedora 31 release cycle. If your Change is in a testable state, please set the status to MODIFIED. If this Change will not be ready for Fedora 31, please set the version to rawhide.

The 100% code complete deadline is Tue 2019-08-27.

Comment 10 Florian Weimer 2019-08-14 18:23:21 UTC
We will likely have to move out this work again.

Comment 11 Ben Cotton 2020-02-11 15:49:18 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.

Comment 12 Ben Cotton 2020-02-28 15:36:04 UTC
I don't see any activity on this for F32. Should I defer to F33 or close it and have you resubmit when ready?

Comment 13 Florian Weimer 2020-02-28 16:18:22 UTC
I will try to get this done for Fedora 33. An odd-numbered release is a much better fit anyway because there's no GCC rebase, so integrating this change will be easier.

Comment 14 Ben Cotton 2020-02-28 16:22:44 UTC
Sounds good, thank you

Comment 15 Florian Weimer 2020-07-24 13:39:26 UTC
This change will not make it into Fedora 33.

Comment 16 Ben Cotton 2020-07-24 15:28:23 UTC
Do you want to try again for F34 or should I close the tracker and let you resubmit later when you're ready?

Comment 17 Florian Weimer 2020-07-24 15:32:58 UTC
I want to try again for Fedora 34. Thanks.

Comment 18 Ben Cotton 2021-02-10 21:23:43 UTC
We have reached the 'Code Complete (testable)' milestone in the Fedora 34 release cycle. If your Change is in a testable state, please set the status to MODIFIED. If this Change will not be ready for Fedora 34, please set the version to rawhide.

The 100% code complete deadline is Tue 2021-02-23.

Comment 19 Ben Cotton 2021-02-16 15:52:06 UTC
Reminder: The change complete (100% complete) deadline for Fedora 34 changes is Tuesday 23 February. At that point, changes should be 100% code complete, along with supporting documentation where appropriate. Please indicate this by setting the tracker bug for your change to ON_QA.

Comment 20 Florian Weimer 2021-02-16 16:02:37 UTC
Sorry, this needs to be moved out again.

Comment 21 Ben Cotton 2021-08-10 12:32:51 UTC
Today is the "Code complete (testable)" deadline in the Fedora Linux 35 release schedule:
https://fedorapeople.org/groups/schedule/f-35/f-35-key-tasks.html

If this Change is complete enough to be tested, please indicate this by setting this bug to the MODIFIED status. (If it is 100% complete, you can set it to ON_QA).

If you wish to defer this Change to Fedora Linux 36, please needinfo bcotton.

Comment 22 Florian Weimer 2021-08-10 12:34:27 UTC
(In reply to Ben Cotton from comment #21)
> If you wish to defer this Change to Fedora Linux 36, please needinfo
> bcotton.

Sorry, this needs to be deferred again.

Comment 23 Ben Cotton 2022-02-08 21:07:59 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 36 development cycle.
Changing version to 36.

Comment 24 Ben Cotton 2022-02-08 21:15:06 UTC
Today we reached the Code Complete (testable) milestone in the F36 schedule: https://fedorapeople.org/groups/schedule/f-36/f-36-key-tasks.html

All code for this change should be complete enough for testing. You can indicate this by setting the bug status to MODIFIED. (If the code is fully complete, you can go ahead and set it to ON_QA.)

If you need to defer this Change to F37, please needinfo bcotton.

Comment 25 Ben Cotton 2022-02-22 16:30:55 UTC
We have reached the 'Change complete (100% complete) deadline in the Fedora Linux 36 release schedule.

At this time, all Changes should be fully complete. Indicate this by setting this tracking bug to ON_QA.

If you need to defer this Change to a subsequent release, please needinfo me.

Comment 26 Ben Cotton 2022-03-02 17:29:13 UTC
Deferring to F37 per FESCo: https://meetbot.fedoraproject.org/teams/fesco/fesco.2022-03-01-18.03.log.html#l-100

Comment 27 Ben Cotton 2022-08-09 16:02:52 UTC
Today we reached the Code Complete (Testable) milestone on the F37 schedule: https://fedorapeople.org/groups/schedule/f-37/f-37-key-tasks.html

At this time, all F37 Changes should be complete enough to be testable. You can indicate this by setting this tracker to the MODIFIED status. If the Change is 100% code complete, you can set the tracker to ON_QA. If you need to defer this Change to F38, please NEEDINFO me.

Changes that have not reached at least the MODIFIED status will be given to FESCo for evaluation of contingency plans.

Comment 28 Florian Weimer 2022-08-15 04:48:19 UTC
Still not done, still on my to-do list. Sorry.

Comment 29 Ben Cotton 2022-08-15 13:17:47 UTC
No problem. I've done the paperwork to push it to F38.

Comment 30 Ben Cotton 2023-02-07 14:27:33 UTC
Today we reached the Code Complete (Testable) milestone on the F38 schedule: https://fedorapeople.org/groups/schedule/f-38/f-38-key-tasks.html

At this time, all F38 Changes should be complete enough to be testable. You can indicate this by setting this tracker to the MODIFIED status. If the Change is 100% code complete, you can set the tracker to ON_QA. If you need to defer this Change to F39, please NEEDINFO me.

Changes that have not reached at least the MODIFIED status will be given to FESCo for evaluation of contingency plans.

Comment 31 Ben Cotton 2023-02-22 19:30:21 UTC
FESCo has dropped this Change. It may be resubmitted when the owner is ready to move forward.
https://meetbot.fedoraproject.org/fedora-meeting/2023-02-21/fesco.2023-02-21-17.00.log.html