Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at

Bug 1602096

Summary: debuginfo package creation fails due to compressed DWARF information on rawhide (f29)
Product: [Fedora] Fedora Reporter: Lokesh Mandvekar <lsm5>
Component: rpmAssignee: Packaging Maintenance Team <packaging-team-maint>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: amurdaca, carl, dwalsh, fkluknav, fweimer, igor.raits, jcajka, kshlmster, lemenkov, lsm5, mjw, nalin, packaging-team-maint, pmatilai, pmoravco, quantum.analyst, renich, vbatts, vmukhame, zebob.m
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-11-16 01:11:04 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1602938, 1604024, 1604112, 1604134, 1604195, 1604526    

Description Lokesh Mandvekar 2018-07-17 19:44:09 UTC
Description of problem:
This is probably a golang version issue, but anyway, filing it under buildah first.

Enabling debuginfo packages on f29 gives this: 

Provides: buildah = buildah(x86-64) =
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(FileDigests) <= 4.6.0-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires: rtld(GNU_HASH)
Processing files:
RPM build errors:
error: Empty %files file /builddir/build/BUILD/buildah-a9895bd41d742117f3480a620a466a363e3d3165/debugsourcefiles.list
    Empty %files file /builddir/build/BUILD/buildah-a9895bd41d742117f3480a620a466a363e3d3165/debugsourcefiles.list
Child return code was: 1
EXCEPTION: [Error()]
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/mockbuild/", line 89, in trace
    result = func(*args, **kw)
  File "/usr/lib/python3.6/site-packages/mockbuild/", line 582, in do
    raise exception.Error("Command failed. See logs for output.\n # %s" % (command,), child.returncode)
mockbuild.exception.Error: Command failed. See logs for output.
 # bash --login -c /usr/bin/rpmbuild -bb --target x86_64 --nodeps /builddir/build/SPECS/buildah.spec

Additional info:

This works just fine on f28 for the same dist-git source. I notice golang is 1.10.3 on f28, but 1.11.0.beta1 on f29, so maybe that's what causes this issue?

Comment 1 Lokesh Mandvekar 2018-07-17 23:41:26 UTC
This happens with cri-o as well, so quite likely a golang issue. Moving to golang..

Comment 2 Jakub Čajka 2018-07-18 12:08:54 UTC
Yes, this started with Go1.11 as it is now compressing DWARF debug information by default. Unfortunately the breakage lies in the rpm/debuginfo as it seems to not be able to parse the compressed sections. 

I have turned off the default DWARF compression for time being in Golang(golang-1.11-0.beta1.2 is building right now), until the rpm/debuginfo can be fixed. This should unblock any package that fails in the upmentioned fashion. 


Comment 3 Mark Wielaard 2018-07-19 09:41:44 UTC
There are at least two packaging tools, rmp debugedit and dwz, which don't deal with DWARF compressed ELF sections. The easiest workaround for that would be to explicitly decompress any that encounters.

That could be done by doing something (untested) like the following:

diff --git a/scripts/ b/scripts/
index 90a4494..7b01bc0 100755
--- a/scripts/
+++ b/scripts/
@@ -357,6 +357,9 @@ do_file()
   get_debugfn "$f"
   [ -f "${debugfn}" ] && return
+  echo "explicitly decompress any DWARF compressed ELF sections in $f"
+  eu-elfcompress -q -p -t none "$f"
   echo "extracting debug info from $f"
   # See also cpio SOURCEFILE copy. Directories must match up.

Comment 4 Elliott Sales de Andrade 2018-07-19 22:03:15 UTC
*** Bug 1601220 has been marked as a duplicate of this bug. ***

Comment 5 Kaushal 2018-07-20 13:50:20 UTC
glusterd2 was hit with the same issue (bz#1604134). I can confirm that the workaround works [1].


Comment 6 Igor Raits 2018-07-25 06:53:01 UTC
Should be fixed with latest elfutils + rpm.

Comment 7 Carl George 2018-11-15 22:54:50 UTC
I'm seeing this same behavior while working on a new package.

My mock chroot is seeing these versions:


Comment 8 Carl George 2018-11-15 23:02:25 UTC
I get the same result on F27, F28, and F29.  Here is the spec file and SRPM I'm working with.

Comment 9 Robert-André Mauchin 🐧 2018-11-15 23:34:06 UTC
 If you don't build any binary, remove:


 Otherwise with a %build section, the packaging process tries to find debuginfo data.

Comment 10 Carl George 2018-11-16 01:11:04 UTC

That fixed it, thanks Robert.  Sorry for the noise everyone.

Comment 11 Mark Wielaard 2018-11-16 07:38:22 UTC
No worries. The error message isn't very helpful. Hopefully someone seeing the error message finds this bug report and sees the actual fix.