Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 161410

Summary: finance quotes broken with "There was a system error while retrieving the price quotes"
Product: [Fedora] Fedora Reporter: Aaron VanDevender <sig>
Component: gnucashAssignee: Bill Nottingham <notting>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-04-07 14:53:24 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Aaron VanDevender 2005-06-23 06:00:23 UTC
Description of problem:
after running update-finance-quote, running gnucash, opening up the price
editor, and pressing the "get quotes" button, gnucash produces an error dialog
that says "There was a system error while retrieving the price quotes." 

Version-Release number of selected component (if applicable):
gnucash-1.8.11-3

How reproducible:
Always

Steps to Reproduce:
1. run update-finance-quote
2. run gnucash
3. get quotes
  
Actual results:
Error dialog, and no quotes

Expected results:
gnucash should retrieve quotes from the net.

Comment 1 Aaron VanDevender 2005-06-30 02:33:13 UTC
I fixed this problem by running

# cpan install HTML::TableExtract

I don't know if this dependancy wasn't included in Finance::Quote like it should
be, or if something else messed up when I ran update-finance-quote, but that is
the solution.

Comment 2 Bill Nottingham 2006-04-07 14:53:24 UTC
It should be pulled in by the finance::quote dependencies. Probably best fixed
by packaging perl-finanace-quote for extras... request going in.

*** This bug has been marked as a duplicate of 188261 ***