Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1624838

Summary: package python3-behave-1.2.6-1.fc29.noarch conflicts with python2-behave < 1.2.6 provided by python2-behave-1.2.5-23.fc28.noarch
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: fedora-obsolete-packagesAssignee: Miro Hrončok <mhroncok>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 29CC: gmarr, j, mhroncok
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedFreezeException
Fixed In Version: fedora-obsolete-packages-29-21 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-09-05 01:09:10 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1517012    

Description Miro Hrončok 2018-09-03 12:15:26 UTC
python2-behave was removed, but nothing obsoletes it. this breaks update without --allowerasing.


Error: 
 Problem: problem with installed package python2-behave-1.2.5-23.fc28.noarch
  - package python3-behave-1.2.6-1.fc29.noarch conflicts with python2-behave < 1.2.6 provided by python2-behave-1.2.5-23.fc28.noarch
  - conflicting requests
  - nothing provides python(abi) = 3.6 needed by python3-behave-1.2.5-23.fc28.noarch
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages)

Comment 1 Fedora Blocker Bugs Application 2018-09-03 12:16:26 UTC
Proposed as a Freeze Exception for 29-beta by Fedora user churchyard using the blocker tracking app because:

 Blocks updates.

Comment 2 Fedora Update System 2018-09-03 12:23:25 UTC
fedora-obsolete-packages-29-21 python-behave-1.2.6-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-707171340f

Comment 3 Fedora Update System 2018-09-03 12:23:37 UTC
fedora-obsolete-packages-29-21 python-behave-1.2.6-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-707171340f

Comment 4 Fedora Update System 2018-09-04 09:03:12 UTC
fedora-obsolete-packages-29-21, python-behave-1.2.6-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-707171340f

Comment 5 Geoffrey Marr 2018-09-04 20:45:43 UTC
Discussed during the 2018-09-04 blocker review meeting: [1]

The decision to classify this bug as an "AcceptedFreezeException" was made as this prevents upgrades without --allowerasing which can be destructive; it merits an FE to allow upgrades with this package and without updates-testing or --allowerasing to proceed.

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-09-04/f29-blocker-review.2018-09-04-16.01.txt

Comment 6 Fedora Update System 2018-09-05 01:09:10 UTC
fedora-obsolete-packages-29-21, python-behave-1.2.6-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.