Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1669635

Summary: enki: FTBFS in Fedora rawhide
Product: [Fedora] Fedora Reporter: Raphael Groner <projects.rg>
Component: enkiAssignee: Raphael Groner <projects.rg>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: rawhideCC: kde-sig, projects.rg, rdieter, than
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://apps.fedoraproject.org/koschei/package/enki
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-02-21 20:27:28 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1669698    

Description Raphael Groner 2019-01-25 20:03:53 UTC
Description of problem:
Package enki fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
18.08.0-1.fc30

Steps to Reproduce:
koji build --scratch f30 enki-18.08.0-1.fc30.src.rpm

Additional info:
This package is tracked by Koschei. See:
http://apps.fedoraproject.org/koschei/package/enki

Comment 1 Raphael Groner 2019-01-25 20:10:07 UTC
Bug exists from sources already merged into branch F29, too.

Comment 2 Raphael Groner 2019-01-25 20:11:57 UTC
What's wrong here?

Comment 3 Raphael Groner 2019-01-25 20:13:23 UTC
ERROR: Command failed: 
 # /usr/bin/dnf builddep --installroot /var/lib/mock/f30-build-15000897-1069577/root/ --setopt=install_weak_deps=0 /var/lib/mock/f30-build-15000897-1069577/root//builddir/build/SRPMS/enki-18.08.0-1.fc30.src.rpm --setopt=tsflags=nocontexts
No matching package to install: 'python3-qt5-webengine'
Not all dependencies satisfied
Error: Some packages could not be found.

Comment 4 Raphael Groner 2019-01-25 22:46:40 UTC
FTBFS is somehow reproducible but now I got another error:

Running transaction test
Error: Transaction check error:
  file /usr/lib/gstreamer-1.0/libgstcompositor.so conflicts between attempted installs of gstreamer1-plugins-bad-free-1.14.4-1.fc30.i686 and gstreamer1-plugins-base-1.15.1-1.fc30.i686

Taking the bug back because obviously yet another dependeny failed.

Comment 5 Raphael Groner 2019-01-29 07:17:59 UTC
https://koji.fedoraproject.org/koji/taskinfo?taskID=32315243

Maybe failures temporarily due to updates done to glibc and other core packages.

Comment 6 Raphael Groner 2019-02-04 18:33:11 UTC
This happens again.

No matching package to install: 'python3-qt5-webengine'

https://apps.fedoraproject.org/koschei/build/5988961

Comment 7 Rex Dieter 2019-02-05 15:54:01 UTC
that package is clearly available, but may not be installable due to dependencies (unfortunately, logs don't include why apparently)

Comment 8 Raphael Groner 2019-02-21 20:27:28 UTC
Magically fixed.