Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1676474

Summary: Broken gir data for gdk_pixbuf_new_from_inline
Product: [Fedora] Fedora Reporter: Daniel BerrangĂ© <berrange>
Component: gdk-pixbuf2Assignee: Matthias Clasen <mclasen>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 29CC: gnome-sig, klember, mclasen
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: gdk-pixbuf2-2.38.0-6.fc29 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-02-15 02:38:36 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1627117    

Description Daniel Berrangé 2019-02-12 12:04:41 UTC
Description of problem:
perl-Gtk3 is failing to rebuild from source in rawhide and Fedora 30 because of broken GIR data for  GdkPixdata's   gdk_pixbuf_new_from_inline API:

GLib-GIO-Message: 11:57:56.999: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.
Gtk3::Gdk::Pixbuf::new_from_inline: passed too few parameters (expected 4, got 3) at t/overrides.t line 762.
# Looks like your test exited with 255 just after 162.
t/overrides.t .................. 

This was reported upstream by Debian:

  https://gitlab.gnome.org/GNOME/gdk-pixbuf/issues/92

Please pull the patches mentioned in that ticket into Fedora 29 and Fedora 30 ASAP, so I can resolve the FTBFS for perl-Gtk3

Version-Release number of selected component (if applicable):
gdk-pixbuf2-2.38.0-4.fc29.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Try to build perl-Gtk3
2.
3.

Actual results:
Test suite fails with

GLib-GIO-Message: 11:57:56.999: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.
Gtk3::Gdk::Pixbuf::new_from_inline: passed too few parameters (expected 4, got 3) at t/overrides.t line 762.
# Looks like your test exited with 255 just after 162.
t/overrides.t .................. 


Expected results:
Tests succeed.

Additional info:

Comment 2 Fedora Update System 2019-02-12 13:07:40 UTC
gdk-pixbuf2-2.38.0-6.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-7c134bf772

Comment 3 Fedora Update System 2019-02-12 20:26:17 UTC
gdk-pixbuf2-2.38.0-6.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-7c134bf772

Comment 4 Fedora Update System 2019-02-15 02:38:36 UTC
gdk-pixbuf2-2.38.0-6.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.