Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1679274

Summary: Syntax error in default exim.conf
Product: [Fedora] Fedora Reporter: Tom Hughes <tom>
Component: eximAssignee: Jaroslav Škarvada <jskarvad>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 29CC: bennie.joubert, dwmw2, jskarvad, tim, tremble
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: exim-4.92-4.fc28 exim-4.92-4.fc29 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-03-13 19:05:25 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Tom Hughes 2019-02-20 19:02:13 UTC
Description of problem:

In addition to a large number of changes that probably shoudln't have been introduced in F29 there is a syntax error in exim.conf with the 4.92 update:

2019-02-20 18:57:03 Exim configuration error in line 122 of /etc/exim/exim.conf:
  option setting expected: +acl_smtp_mail =        acl_check_mail

The leading + on that line is not valid....

Version-Release number of selected component (if applicable):

exim-4.92-1.fc29.x86_64

Comment 1 Tom Hughes 2019-02-20 20:36:29 UTC
Also was the greylist stuff supposed to get moved from the data acl to the mime acl?

Comment 2 Tim Landscheidt 2019-03-02 00:52:36 UTC
This also affects Fedora 28.  (It would be nice to add a %check section that (maybe in addition to running Exim's own test suite which is always a good idea) checks that the configuration file is valid by running something like "./exim -C ./src/configure.default -bV".)

NB: Due to this bug, currently mail from cron & Co. gets silently discarded.  To work around, edit /etc/exim/exim.conf à la:

| --- /etc/exim/exim.conf~        2019-02-11 21:35:34.000000000 +0000
| +++ /etc/exim/exim.conf 2019-03-02 00:51:16.872940421 +0000
| @@ -119,7 +119,7 @@
|  # manual for details. The lists above are used in the access control lists for
|  # checking incoming messages. The names of these ACLs are defined here:

| -+acl_smtp_mail =        acl_check_mail
| +acl_smtp_mail =         acl_check_mail
|  acl_smtp_rcpt =         acl_check_rcpt
|  .ifdef _HAVE_PRDR
|  acl_smtp_data_prdr =    acl_check_prdr

Comment 3 Tim Landscheidt 2019-03-02 18:15:00 UTC
I've pushed a fix for Fedora 28 to https://src.fedoraproject.org/rpms/exim/pull-request/3.  Please note that this does not address Tom's question in comment #1.

Comment 4 Jaroslav Škarvada 2019-03-04 09:41:14 UTC
(In reply to Tom Hughes from comment #0)
> Description of problem:
> 
> In addition to a large number of changes that probably shoudln't have been
> introduced in F29 there is a syntax error in exim.conf with the 4.92 update:
>
Sorry about it. In the past upstream had LTS versions, now it obsoleted everything older than 4.92. It's usually pain to maintain unsupported obsoleted versions, hence the rebase.

Comment 5 Jaroslav Škarvada 2019-03-04 09:44:49 UTC
(In reply to Tim Landscheidt from comment #3)
> I've pushed a fix for Fedora 28 to
> https://src.fedoraproject.org/rpms/exim/pull-request/3.  Please note that
> this does not address Tom's question in comment #1.

Thanks, merged.

Comment 6 Jaroslav Škarvada 2019-03-04 11:07:12 UTC
(In reply to Tom Hughes from comment #1)
> Also was the greylist stuff supposed to get moved from the data acl to the
> mime acl?

Sorry, merge error, is exim-4.92-4.fc31 OK? I am going to fix other branches as well.

Comment 7 Fedora Update System 2019-03-04 12:47:55 UTC
exim-4.92-4.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-754bb22186

Comment 8 Fedora Update System 2019-03-04 12:51:40 UTC
exim-4.92-4.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-adf4161f4b

Comment 9 Fedora Update System 2019-03-05 04:37:39 UTC
exim-4.92-4.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-adf4161f4b

Comment 10 Fedora Update System 2019-03-05 14:43:58 UTC
exim-4.92-4.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-754bb22186

Comment 11 Fedora Update System 2019-03-13 19:05:25 UTC
exim-4.92-4.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2019-03-15 18:28:45 UTC
exim-4.92-4.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.