Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1688082

Summary: [ko] Hangul input does not commit in Terminal, Firefox urlbar, Libreoffice
Product: [Fedora] Fedora Reporter: sangu <sangu.fedora>
Component: mutterAssignee: Florian Müllner <fmuellner>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: medium    
Version: 30CC: awilliam, cgarnach, fmuellner, gmarr, gnome-sig, i18n-bugs, jadahl, otaylor, pwu, robatino, shawn.p.huang, sshedmak, tfujiwar, walters
Target Milestone: ---Keywords: i18n, Regression, Reopened
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: AcceptedFreezeException AcceptedBlocker
Fixed In Version: mutter-3.32.0-2.fc30 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-03-28 17:41:18 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1574714, 1574715    

Description sangu 2019-03-13 05:20:27 UTC
Description of problem:
Hangul input does not commit in gnome-terminal or libreoffice

Version-Release number of selected component (if applicable):
1.5.1-3.fc30.x86_64

How reproducible:
always

Steps to Reproduce:
1. gnome-terminal or libreoffice starts
2. input "r" "k" with ibug-hangul 
3.

Actual results:
(empty)

Expected results:
가

Additional info:

Comment 1 Jens Petersen 2019-03-13 07:20:27 UTC
I could reproduce in
Fedora-Workstation-Live-x86_64-30-20190312.n.0.iso

ibus-hangul has not changed in a while so moving to ibus first.

Comment 2 fujiwara 2019-03-13 07:35:14 UTC

*** This bug has been marked as a duplicate of bug 1684424 ***

Comment 3 fujiwara 2019-03-22 03:11:48 UTC
I think the fix of bug 1632981 was deleted in mutter 3.32.0.

https://src.fedoraproject.org/rpms/mutter/pull-request/13#request_diff

Fedora 29 mutter 3.30.2 includes that fix but Fedora 30 mutter 3.32.0 does not include it.

Comment 4 Jens Petersen 2019-03-22 05:04:08 UTC
This an approved F29FinalBlocker, so proposing also as a Final Blocker for F30.

Comment 5 sandeep shedmake 2019-03-22 05:53:10 UTC
Co-incidentally, Hangul input work (commit) with gedit-3.32-0-1.fc30.

Comment 6 Jens Petersen 2019-03-22 06:36:29 UTC
This only affect the application listed in the summary AFAIK.

Comment 7 Geoffrey Marr 2019-03-25 18:44:18 UTC
Discussed during the 2019-03-25 blocker review meeting: [1]

The decision to classify this bug as an "AcceptedBlocker" and an "AcceptedFreezeException" was made as having input methods not working in major applications is obviously a serious bug, and affects live image so cannot be fully fixed with an update. This is also accepted as a Final blocker on the same basis the equivalent F29 bug (#1632981) was accepted: it violates the "basic functionality test" criterion when affected input methods are used, certainly including Korean and likely also affecting some Chinese IMs.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2019-03-25/f30-blocker-review.2019-03-25-16.01.txt

Comment 8 Fedora Update System 2019-03-25 21:28:32 UTC
mutter-3.32.0-2.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-58e5fe7ef3

Comment 9 Adam Williamson 2019-03-26 15:16:34 UTC
Can you please test the updated mutter and confirm that it is fixed? Thanks!

Comment 10 Fedora Update System 2019-03-27 00:45:05 UTC
mutter-3.32.0-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-58e5fe7ef3

Comment 11 Jens Petersen 2019-03-28 08:29:03 UTC
This LGTM, thanks

I tested Fedora-Workstation-Live-x86_64-30_Beta-1.8.iso.

Comment 12 Adam Williamson 2019-03-28 14:08:55 UTC
Great, thank you.

Comment 13 Adam Williamson 2019-03-28 16:40:52 UTC
As we actually got this fixed for Beta, I'm dropping CommonBugs.

Comment 14 Fedora Update System 2019-03-28 17:41:18 UTC
mutter-3.32.0-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Red Hat Bugzilla 2023-09-14 05:25:22 UTC
The needinfo request[s] on this closed bug have been removed as they have been unresolved for 1000 days