Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1691674

Summary: searching for language causes gnome-control-center to crash
Product: [Fedora] Fedora Reporter: Jens Petersen <petersen>
Component: gnome-control-centerAssignee: Pete Walter <walter.pete>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 30CC: alciregi, awilliam, gmarr, gnome-sig, walter.pete
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedFreezeException
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-03-25 16:36:26 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1574714    

Description Jens Petersen 2019-03-22 08:15:30 UTC
Description of problem:
control-center crashes when searching for a language.

Version-Release number of selected component (if applicable):
gnome-control-center-3.32.0.1-1.fc30

How reproducible:
100%

Steps to Reproduce:
1. Go into Region and language settings
2. Click on Language
3. Scroll down and click on ":" (more)
4. Start typing "eng"

Actual results:
gnome-control-center disappears (crashes)

Expected results:
no crash

Additional info:
abrt is not taking backtraces ;)
But this is highly reproducible in F30.

Comment 1 Alessio 2019-03-22 20:15:33 UTC
Please look at bug 1685251

Comment 2 Adam Williamson 2019-03-25 16:32:44 UTC
This does look like a dupe of that, yeah.

Note if abrt is on the fritz, 'coredumpctl' may possibly be working instead...you can try 'coredumpctl list', coredumpctl gdb'...

Comment 3 Adam Williamson 2019-03-25 16:36:26 UTC

*** This bug has been marked as a duplicate of bug 1685251 ***

Comment 4 Geoffrey Marr 2019-03-25 18:38:07 UTC
Discussed during the 2019-03-25 blocker review meeting: [1]

The decision to classify this bug as an "AcceptedFreezeException" was made as this is a fairly prominent crasher that is visible in the live image and so cannot be fixed with an update. Note we will close the bug as a duplicate of the earlier 1685251 (which has a backtrace) and mark that as accepted.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2019-03-25/f30-blocker-review.2019-03-25-16.01.txt