Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1708054

Summary: gscan2pdf warns about missing pdftk tool
Product: [Fedora] Fedora Reporter: MicMor <michel.morisot>
Component: gscan2pdfAssignee: Petr Pisar <ppisar>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: 30CC: bob, ppisar, rakesh.pandit, sven
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: gscan2pdf-2.5.2-2.fc31 gscan2pdf-2.5.2-2.fc30 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1708522 (view as bug list) Environment:
Last Closed: 2019-05-18 01:01:37 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description MicMor 2019-05-09 05:04:17 UTC
Description of problem:


Attention : Il manque des packages
PDF encryption requires pdftk

Attention: Packages are missing
PDF encryption requires pdftk


Version-Release number of selected component (if applicable):


2.5.2

How reproducible:


Steps to Reproduce:
1. start gscan2pdf

2. start gscan2pdf

3.

Actual results:


Expected results:


Additional info:

F30 wayland gnome  
F30 xorg gnome 

same error

Comment 1 Petr Pisar 2019-05-09 07:51:22 UTC
The is just a warning about a missing optional feature and shown only once. If you start gscan2pdf again, the warning won't be shown anymore. gscan2pdf does depend on pdftk because:

(1) It's only an optional feature that not everybody needs.

(2) pdftk was removed from Fedora 20 due to technical and license issues. See bug #1033302.

I will try to patch out the warning, but I will keep the functionality because users can obtain pdftk in different means (e.g. by purchasing a proprietary license).

Comment 2 MicMor 2019-05-09 08:21:55 UTC
Okay, thanks for the F31, but is the fix for the F30?

Comment 3 Fedora Update System 2019-05-09 08:51:10 UTC
gscan2pdf-2.5.2-2.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-b6c9a36249

Comment 4 Bob Schultz 2019-05-09 20:49:32 UTC
The update fixes pdftk problem, but there's another bug. Changing scan resolution from the default 100 ppi to 200 ppi creates invalid syntax used for sane parameters:
"default-scan-options" : {
      "backend" : [
         {
            "resolution" : 200
         }
      ]
   },
   "device" : "hp5590:libusb:001:006",
   "device blacklist" : null,
   "downsample" : "",
   "downsample dpi" : 150,
   "frontend" : "libimage-sane-perl",
   "image type" : null,
   "keywords" : null,
   "keywords-suggestions" : null,
   "libimage-sane-perl version" : "0.14",
   "message" : {
      "Error processing with tesseract: Detected %%d diacritics" : {},
      "Some pages have not been saved.\nDo you really want to quit?" : {},
      "gscan2pdf: sane_start: Invalid argument" : {}
   },

This is first use of scanner since f29-->f30 upgrade a week ago. gscan2pdf worked flawlessly for years prior.

Comment 5 Fedora Update System 2019-05-10 02:06:02 UTC
gscan2pdf-2.5.2-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-b6c9a36249

Comment 6 Petr Pisar 2019-05-10 07:17:37 UTC
(In reply to Bob Schultz from comment #4)
> The update fixes pdftk problem, but there's another bug.

That's a different issue. Let's talk about it in bug #1708522.

Comment 7 Fedora Update System 2019-05-18 01:01:37 UTC
gscan2pdf-2.5.2-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.