Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1747650

Summary: pocketsphinx fails to build with Python 3.8 on Fedora 32+
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: pocketsphinxAssignee: W. Michael Petullo <redhat>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: rawhideCC: loganjerry, mike, redhat
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-10-17 11:01:41 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1750908, 1750909, 1686977    

Description Miro Hrončok 2019-08-31 12:59:09 UTC
pocketsphinx fails to build with Python 3.8.0b3 in Fedora 32.

See the build failures at https://koji.fedoraproject.org/koji/search?match=glob&type=package&terms=pocketsphinx

It is a dependency problem:

No matching package to install: 'pkgconfig(sphinxbase)'

It is not important the problem is not relevant to Python 3.8, this issue is blocking the Python 3.8 rebuilds.
If this package won't build with 3.8, it won't be installable, along with all its dependent packages, in Fedora 32 and further.

Furthermore, as it fails to install, its dependent packages will fail to install and/or build as well.

Please rebuild the package in Fedora 32 (rawhide).

Let us know here if you have any questions. Thank You!

Comment 1 Miro Hrončok 2019-09-16 08:56:38 UTC
I think that this package shall be retired. It has dependencies missing for couple releases. WDYT?

Comment 2 W. Michael Petullo 2019-10-13 17:10:52 UTC
It looks like sphinxbase will be easy to fix; a patch follows. If we make this change and unorphan sphinxbase, then I should be able to fix pocketsphinx too. The problem seems to follow from pulling Python 2 out of Fedora.

diff --git a/sphinxbase.spec b/sphinxbase.spec
index 5d8efc9..3a3fbce 100644
--- a/sphinxbase.spec
+++ b/sphinxbase.spec
@@ -1,6 +1,6 @@
 Name:           sphinxbase
 Version:        5prealpha
-Release:        5%{?dist}
+Release:        6%{?dist}
 Summary:        Common library for CMU Sphinx voice recognition products
 
 License:        BSD
@@ -81,6 +81,7 @@ done
 
 %build
 export CPPFLAGS="-I %{_includedir}/openblas"
+export PYTHON="python3"
 %configure --disable-static --with-python=%{__python3}
 
 # Get rid of undesirable hardcoded rpaths; workaround libtool reordering
@@ -144,6 +145,9 @@ rm -f %{buildroot}%{_libdir}/*.la
 %{python3_sitearch}/*
 
 %changelog
+* Sun Oct 13 2019 W. Michael Petullo <mike> - 5prealpha-6
+- More work to switch to Python 3
+
 * Sun Feb 03 2019 Fedora Release Engineering <releng> - 5prealpha-5
 - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

Comment 3 W. Michael Petullo 2019-10-13 17:24:43 UTC
See also https://pagure.io/releng/issue/8898.

Comment 4 W. Michael Petullo 2019-10-17 02:06:19 UTC
I just brought sphinxbase back into Rawhide, so this should be fixed soon. I am waiting on the sphinxbase package to become available in the build system.

Comment 5 Red Hat Bugzilla 2023-09-14 05:42:41 UTC
The needinfo request[s] on this closed bug have been removed as they have been unresolved for 1000 days