Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1751372

Summary: [Wayland] [regression] After updating to version 69, switching between tabs doesn't always update the window's contents
Product: [Fedora] Fedora Reporter: Tadej Janež <tadej.j>
Component: firefoxAssignee: Martin Stransky <stransky>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 30CC: 0xalen+redhat, anto.trande, dimitris.on.linux, dueno, gecko-bugs-nobody, jhorak, john.j5live, kengert, pjasicek, quantum.analyst, rhughes, rstrode, sandmann, stransky
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: firefox-69.0.1-3.fc31 firefox-69.0.1-3.fc30 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-09-21 00:03:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1054334    
Attachments:
Description Flags
Screencast of switchiing between tabs demonstrating that this doesn't always update the window's contents. none

Description Tadej Janež 2019-09-11 20:38:04 UTC
Created attachment 1614228 [details]
Screencast of switchiing between tabs demonstrating that this doesn't always update the window's contents.

Description of problem:
After upgrading from version 68 to 69, I noticed that switching between tabs doesn't always update the window's contents.


Version-Release number of selected component (if applicable):
firefox-wayland-69.0-2.fc30.x86_64

How reproducible:
Very often.


Steps to Reproduce:
1. Open two or more tabs.
2. Switch between then rapidly.

Actual results:
The window's contents is not immediately updated, but only after hoovering over it with a mouse cursor or maximizing & unmaximizing the entire window.

Expected results:
The window's contents is immediately updated when switching between tabs within the same window.


Additional info:
See the attached screencast for additional details.

Comment 1 Martin Stransky 2019-09-12 05:43:11 UTC
This is a dupe of Bug 1750533. firefox-69.0-5 should fix that (https://koji.fedoraproject.org/koji/taskinfo?taskID=37604373).

*** This bug has been marked as a duplicate of bug 1750533 ***

Comment 2 Martin Stransky 2019-09-12 06:29:03 UTC
Perhaps not a dupe. Upsream bug https://bugzilla.mozilla.org/show_bug.cgi?id=1580152

Comment 3 Tadej Janež 2019-09-12 07:33:27 UTC
> Perhaps not a dupe. Upsream bug https://bugzilla.mozilla.org/show_bug.cgi?id=1580152

I've read the upstream bug report. Yes, I think this is the same issue.

Comment 4 Fedora Update System 2019-09-18 06:41:33 UTC
FEDORA-2019-e807812939 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-e807812939

Comment 5 Fedora Update System 2019-09-18 06:41:37 UTC
FEDORA-2019-f5280ee0db has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-f5280ee0db

Comment 6 Fedora Update System 2019-09-19 02:20:21 UTC
firefox-69.0-7.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-e807812939

Comment 7 Fedora Update System 2019-09-19 02:29:47 UTC
firefox-69.0-7.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-f5280ee0db

Comment 8 Fedora Update System 2019-09-19 08:24:22 UTC
FEDORA-2019-7ae551c2bc has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-7ae551c2bc

Comment 9 Fedora Update System 2019-09-19 08:24:28 UTC
FEDORA-2019-2b6fab9eb9 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-2b6fab9eb9

Comment 10 Fedora Update System 2019-09-20 01:56:33 UTC
firefox-69.0.1-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-2b6fab9eb9

Comment 11 Fedora Update System 2019-09-20 02:56:30 UTC
firefox-69.0.1-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-7ae551c2bc

Comment 12 Fedora Update System 2019-09-20 10:14:35 UTC
FEDORA-2019-7f7bace5b4 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-7f7bace5b4

Comment 13 Fedora Update System 2019-09-20 10:14:41 UTC
FEDORA-2019-f7d21d6ef6 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-f7d21d6ef6

Comment 14 Fedora Update System 2019-09-21 00:03:03 UTC
firefox-69.0.1-3.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2019-09-21 01:24:31 UTC
firefox-69.0.1-3.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.