Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at

Bug 175631

Summary: Review Request: fedora-package-config-smart - Configuration files for the smart package manager
Product: [Fedora] Fedora Reporter: Axel Thimm <axel.thimm>
Component: Package ReviewAssignee: Tom "spot" Callaway <tcallawa>
Status: CLOSED NEXTRELEASE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 5CC: fedora-package-review, gauret, rh-bugzilla, tcallawa
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-04-12 12:22:55 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 163779    

Description Axel Thimm 2005-12-13 16:02:25 UTC
Spec Name or Url:
SRPM Name or Url:

Configuration files for smart. These are split off the main package for the same reasons yum's and up2date's config files are split off into fedora-release. These config files (channel) are the *.repo config files from fedora-release transcribed for smart.

Comment 1 Ville Skyttä 2005-12-13 16:28:02 UTC

*** This bug has been marked as a duplicate of 175473 ***

Comment 2 Jochen Schmitt 2006-02-22 17:53:33 UTC
+ rpmlint to srpm ok.
+ Local build worked fine.

- rpmlint for rpms complaints:

rpmlint smart-0.40-23.i686.rpm
W: smart conffile-without-noreplace-flag /etc/pam.d/smart-root
W: smart conffile-without-noreplace-flag /etc/security/console.apps/smart-root

rpmlint smart-gui-0.40-23.i686.rpm
W: smart-gui no-documentation

rpmlint smart-update-0.40-23.i686.rpm
W: smart-update no-documentation

- BuildRoot should be %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
? Encoding should be UTF-8
- New upstream release is available.

I have reopen this bug, becouse its was accidently closed.

Comment 3 Ville Skyttä 2006-02-22 19:30:50 UTC
It was not accidentally closed, this *is* a duplicate of bug 175473.

*** This bug has been marked as a duplicate of 175473 ***

Comment 4 Axel Thimm 2006-03-30 22:27:59 UTC
Reopening due to bug 175438 comment 77 and bug 185239

Comment 5 Axel Thimm 2006-04-01 00:44:00 UTC
Updated packages for FC5 are available at:

* Sat Apr  1 2006 Axel Thimm <Axel.Thimm> - 5-4
- Update to Fedora Core 5.

* Tue Dec 13 2005 Axel Thimm <Axel.Thimm> - 4-3
- changed name to fedora-package-config-smart
- Modify to only include what fedora-release includes for yum.

Comment 6 Tom "spot" Callaway 2006-04-09 23:16:05 UTC

- rpmlint checks return:
E: fedora-package-config-smart no-binary
W: fedora-package-config-smart no-documentation

Both are safe to ignore.

- package meets naming guidelines
- package meets packaging guidelines
- license (GPL) OK
- spec file legible, in am. english
- no real way to check config files against "upstream"
- package compiles on devel (x86)
- no missing BR
- no unnecessary BR
- no locales
- not relocatable
- owns all directories that it creates
- no duplicate files
- permissions ok
- %clean ok
- macro use consistent
- content ok
- no need for -docs
- nothing in %doc
- no need for .desktop file 

APPROVED. One down, one to go.

Comment 7 Ville Skyttä 2006-04-11 19:53:34 UTC
Nitpick: including the source files separately in the SRPM instead of rolling
them in a tarball would be more developer friendly (think CVS checkouts, diffs,
commit mails).

Comment 8 Axel Thimm 2006-04-12 12:22:55 UTC
Having seen the cvs system in action I agree with Ville in the previous comment.
I tried to make the "upstream" sources look more like what is in the
fedora-release package.

Comment 9 Ville Skyttä 2006-04-22 11:28:54 UTC
*** Bug 175473 has been marked as a duplicate of this bug. ***