Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1761156

Summary: pythran fails to build in Fedora 32 with gast 0.3 and Python 3.8
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: pythranAssignee: Miro Hrončok <mhroncok>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: mhroncok, python-sig, sguelton
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: pythran-0.9.4post1-1.fc32 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-12-10 12:56:35 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1747029    
Bug Blocks: 1750908, 1750909, 1686977    

Comment 1 Miro Hrončok 2019-10-13 00:09:29 UTC
I've hit it too early. Here is the actual report:

pythran 0.9.3 or 0.9.3post1 is not compatible yet with gast 0.3.x

The failure visible during the docs build:

+ make -C docs html
make: Entering directory '/builddir/build/BUILD/pythran-0.9.3post1/docs'
sphinx-build -b html -d _build/doctrees . _build/html
Running Sphinx v2.1.2

Configuration error:
There is a programmable error in your configuration file:

Traceback (most recent call last):
  File "/usr/lib/python3.8/site-packages/sphinx/config.py", line 361, in eval_config_file
    execfile_(filename, namespace)
  File "/usr/lib/python3.8/site-packages/sphinx/util/pycompat.py", line 86, in execfile_
    exec(code, _globals)
  File "/builddir/build/BUILD/pythran-0.9.3post1/docs/conf.py", line 19, in <module>
    from pythran import __version__
  File "/builddir/build/BUILD/pythran-0.9.3post1/build/lib/pythran/__init__.py", line 40, in <module>
    from pythran.toolchain import (generate_cxx, compile_cxxfile, compile_cxxcode,
  File "/builddir/build/BUILD/pythran-0.9.3post1/build/lib/pythran/toolchain.py", line 6, in <module>
    from pythran.backend import Cxx, Python
  File "/builddir/build/BUILD/pythran-0.9.3post1/build/lib/pythran/backend.py", line 8, in <module>
    from pythran.analyses import LocalNodeDeclarations, GlobalDeclarations, Scope
  File "/builddir/build/BUILD/pythran-0.9.3post1/build/lib/pythran/analyses/__init__.py", line 12, in <module>
    from .aliases import Aliases, StrictAliases
  File "/builddir/build/BUILD/pythran-0.9.3post1/build/lib/pythran/analyses/aliases.py", line 6, in <module>
    from pythran.syntax import PythranSyntaxError
  File "/builddir/build/BUILD/pythran-0.9.3post1/build/lib/pythran/syntax.py", line 7, in <module>
    from pythran.tables import MODULES
  File "/builddir/build/BUILD/pythran-0.9.3post1/build/lib/pythran/tables.py", line 173, in <module>
    BINARY_UFUNC = {"accumulate": FunctionIntr()}
  File "/builddir/build/BUILD/pythran-0.9.3post1/build/lib/pythran/intrinsic.py", line 94, in __init__
    super(FunctionIntr, self).__init__(**kwargs)
  File "/builddir/build/BUILD/pythran-0.9.3post1/build/lib/pythran/intrinsic.py", line 55, in __init__
    self.args = ast.arguments(
  File "/usr/lib/python3.8/site-packages/gast/gast.py", line 17, in create_node
    assert nbparam in (0, len(Fields)), \
AssertionError: Bad argument number for arguments: 6, expecting 7

make: Leaving directory '/builddir/build/BUILD/pythran-0.9.3post1/docs'
make: *** [Makefile:7: html] Error 2

Comment 2 serge_sans_paille 2019-10-31 06:34:20 UTC
0.9.4 has been released yesterday, it should fix this issue.