Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1778891

Summary: gnome-maps fails to run on current Rawhide
Product: [Fedora] Fedora Reporter: Adam Williamson <awilliam>
Component: gnome-mapsAssignee: Kalev Lember <klember>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: rawhideCC: elad, gnome-sig, klember, nobody+zeenix, philip.wyett, robatino
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-12-02 18:08:13 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1705305    

Description Adam Williamson 2019-12-02 18:05:12 UTC
On current Rawhide images - e.g. https://kojipkgs.fedoraproject.org/compose/rawhide/Fedora-Rawhide-20191202.n.0/compose/Workstation/x86_64/iso/Fedora-Workstation-Live-x86_64-Rawhide-20191202.n.0.iso - gnome-maps fails to run. Run from a console we see:

[liveuser@localhost-live ~]$ gnome-maps 
Inconsistency detected by ld.so: dl-open.c: 459: activate_nodelete: Assertion `!imap->l_init_called || imap->l_type != lt_loaded' failed!

I am not sure what's causing this, honestly. But it clearly violates Final criterion "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test.", so proposing as an F32 Final blocker.

Comment 1 Adam Williamson 2019-12-02 18:08:13 UTC
Aha. Already fixed in glibc apparently.

*** This bug has been marked as a duplicate of bug 1778344 ***