Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1779399

Summary: .gnu.build.attributes problems causing FTBFS on f30, f31
Product: [Fedora] Fedora Reporter: Frank Ch. Eigler <fche>
Component: binutilsAssignee: Nick Clifton <nickc>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 31CC: aoliva, ashankar, dvlasenk, fweimer, jakub, jcajka, mjw, mjw, nickc
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-01-21 14:36:15 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Frank Ch. Eigler 2019-12-03 22:24:00 UTC
On f31 and f30, similar .gnu.build.attributes-related error messages are causing an elfutils COPR build to fail.  On f31, this is observed with the 2.32-29 binutils version (with the note-merging fix); on f30, the same fix is not yet in the buildroot due to bodhi just pushing it.  But we have the same apparent failure, both with and without this .gnu.build.attributes-related fix.

 https://copr.fedorainfracloud.org/coprs/fche/elfutils/build/1123340/

Comment 1 Nick Clifton 2019-12-04 13:00:59 UTC
Hi Frank,

> On f31 and f30, similar .gnu.build.attributes-related error messages are
> causing an elfutils COPR build to fail

Just to be clear, it is error messages from the elfutils tests that are 
blocking the build from completing right ?  The actual build of the
elfutils does succeed.

The issue is that the build is using glibc-2.30-7.fc31 which has corrupted
notes in the crti.o and crtn.o object files.  What we need is a rebuild of
glibc.  This will fix the notes and then the problem should go away.  I
have pinged the Fedora glibc maintainers and requested just such a thing.

Cheers
  Nick

Comment 2 Mark Wielaard 2019-12-04 13:06:21 UTC
(In reply to Nick Clifton from comment #1)
> Just to be clear, it is error messages from the elfutils tests that are 
> blocking the build from completing right ?  The actual build of the
> elfutils does succeed.

The elfutils build as a whole fails, because it expects the testsuite to be zero fail. But yes, the build itself "succeeds" but various (self) tests fail because they encounter corrupt ELF notes.

> The issue is that the build is using glibc-2.30-7.fc31 which has corrupted
> notes in the crti.o and crtn.o object files.  What we need is a rebuild of
> glibc.  This will fix the notes and then the problem should go away.  I
> have pinged the Fedora glibc maintainers and requested just such a thing.

Eep. That would indeed explain it. This is pretty bad, because crti.o and crtn.o are basically included into every binary.

Comment 3 Fedora Update System 2019-12-04 22:07:34 UTC
FEDORA-2019-46ef941af9 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-46ef941af9

Comment 4 Arjun Shankar 2019-12-04 22:13:25 UTC
...and here's the Fedora 30 update for glibc:
https://bodhi.fedoraproject.org/updates/FEDORA-2019-7153dc69ea

Comment 5 Fedora Update System 2019-12-05 01:23:49 UTC
glibc-2.30-8.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-46ef941af9

Comment 6 Fedora Update System 2019-12-05 02:01:17 UTC
glibc-2.29-27.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-7153dc69ea

Comment 7 Jakub ńĆajka 2019-12-05 15:49:47 UTC
For the record I have seen golang tests(cgoshared, cgo dynamic linking, in notes section parsing test) failures with glibc glibc-2.30-7 on most of the 64bit arches. Latest build in glibc-2.30-8.fc31 seems to fix this issue.

Comment 8 Fedora Update System 2019-12-06 05:45:10 UTC
glibc-2.30-8.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2019-12-07 01:31:03 UTC
glibc-2.29-27.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Florian Weimer 2020-01-17 12:11:38 UTC
Has this issue been addressed by now? Thanks.

Comment 11 Mark Wielaard 2020-01-17 13:10:06 UTC
I have since done a success elfutils koji build on f30, f31 and rawhide (testsuite all green, including the self tests). So I believe it has been resolved. But I don't know about copr.

Comment 12 Nick Clifton 2020-01-21 14:36:15 UTC
I am going to close this as resolved then, since I think that there is nothing left that we need to do.