Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1790199

Summary: System stops recognising the sound device after updating to the latest kernels (stable: 5.4.8-200.fc31.x86_64 ; rawhide: 5.5.0-0.rc5.git2.2.fc32.x86_64).
Product: [Fedora] Fedora Reporter: peppermount
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 31CC: airlied, bskeggs, hdegoede, ichavero, itamar, jarodwilson, jeremy, jglisse, john.j5live, jonathan, josef, kernel-maint, linville, masami256, mchehab, mjg59, steved
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-03-03 21:02:50 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
Kernel+ALSA logs for each of 3 mentioned kernels. none

Description peppermount 2020-01-12 14:45:45 UTC
Created attachment 1651654 [details]
Kernel+ALSA logs for each of 3 mentioned kernels.

1. Latest Fedora 31 release with 5.3.7-301.fc31.x86_64 kernel is working fine "out of the box" on my new machine with Intel Corporation Device 02c8 - 8086:02c8 - Subsystem: 1025:140e. But, after the general dnf update it stops recognising the device. I was able (I think) to isolate the problem to the kernel: updating with kernel excluded (like this: 'sudo dnf versionlock add kernel*') does not cause the problem.

2. I was able to reproduce the problem with kernels 5.4.8-200.fc31.x86_64 and 5.5.0-0.rc5.git2.2.fc32.x86_64 (rawhide).

3. Everything worked fine with 5.3.7-301.fc31.x86_64 kernel. It would take time for me to go through every subsequent kernel and isolate where the problem appeared first, but i'm ready to do it if needed.

4. The issue is always reproducible. I reinstalled the whole distro (Workstation and XFCE spin) 4 times, and it reappears every time after the kernel update.

6. I don't think I'm running any additional modules. I don't know if rpmfusion adds anything like that, but i think I updated the rpmfusion and without it - same effect.

Comment 1 Justin M. Forbes 2020-03-03 16:37:42 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 31 kernel bugs.

Fedora 31 has now been rebased to 5.5.7-200.fc31.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 32, and are still experiencing this issue, please change the version to Fedora 32.

If you experience different issues, please open a new bug report for those.

Comment 2 Hans de Goede 2020-03-03 21:02:50 UTC
It looks like your Acer Swift SF314-58 is one of the newer models which use digital mics instead of analog ones (MEMs mics), these mics require a new sound driver called sof-hda, also see bug 1772498.

In some of the recent Fedora kernels there were some issues with the sof-hda driver, but these should all be resolved in the latest 5.5.7 kernel update. Note you do need to also install the "alsa-firmware" for sound to work with the 5.5.7 kernel, we are working on making this automatic. For now to fix the missing firmware files do:

sudo dnf install alsa-firmware

From a terminal, combined with kernel 5.5.7 + the latest alsa-libs and pulseaudio packages this may be enough to make your microphone work, I say may because these new drivers also need some per model setup and so far we have mostly been focussing on getting things to work on the Lenovo X1 7th gen, so your Acer Swift may need a bit more work.

Since all relevant discussion about this is happening in bug 1772498, I'm going to mark this bug as a duplicate of that one. If you still have any issues with 5.5.7 + the latest alsa-libs, alsa-firmware and pulseaudio pkgs please let us know about this in bug 1772498.

*** This bug has been marked as a duplicate of bug 1772498 ***