Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1790625

Summary: updates failed
Product: [Fedora] Fedora Reporter: Brent R Brian <brentrbrian>
Component: dnfAssignee: Lukáš Hrázký <lhrazky>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: high    
Version: 31CC: jmracek, jonathan, jrohel, lhrazky, mblaha, mhatina, packaging-team-maint, pkratoch, rpm-software-management, vmukhame
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: dnf-4.2.21-1.fc31 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-04-18 00:07:05 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Brent R Brian 2020-01-13 19:09:04 UTC
[mrb] $sudo dnf -y update
[sudo] password for mrb: 

Fedora Modular 31 - x86_64 - Updates                                                                                                                                             23 kB/s |  17 kB     00:00    
Fedora Modular 31 - x86_64 - Updates                                                                                                                                            112 kB/s | 298 kB     00:02    
Errors during downloading metadata for repository 'updates-modular':
  - Curl error (23): Failed writing received data to disk/application for http://mirror.atl.genesisadaptive.com/fedora/linux/updates/31/Modular/x86_64/repodata/9f27d1117dcb5a1326a517a513eb06dd7779c421b112ea7c5dfe3a3ed899f950-filelists.xml.zck [Failed writing body (0 != 1600)]
  - Curl error (23): Failed writing received data to disk/application for http://mirror.atl.genesisadaptive.com/fedora/linux/updates/31/Modular/x86_64/repodata/63c98fdb1f5fe4695d459d50b554921c332b8b3dba7a251105f9b73fe35e549c-primary.xml.zck [Failed writing body (0 != 5063)]
Error: Failed to download metadata for repo 'updates-modular': Yum repo downloading error: Downloading error(s): repodata/63c98fdb1f5fe4695d459d50b554921c332b8b3dba7a251105f9b73fe35e549c-primary.xml.zck - Download failed: Curl error (23): Failed writing received data to disk/application for http://mirror.atl.genesisadaptive.com/fedora/linux/updates/31/Modular/x86_64/repodata/63c98fdb1f5fe4695d459d50b554921c332b8b3dba7a251105f9b73fe35e549c-primary.xml.zck [Failed writing body (0 != 5063)]; repodata/9f27d1117dcb5a1326a517a513eb06dd7779c421b112ea7c5dfe3a3ed899f950-filelists.xml.zck - Download failed: Curl error (23): Failed writing received data to disk/application for http://mirror.atl.genesisadaptive.com/fedora/linux/updates/31/Modular/x86_64/repodata/9f27d1117dcb5a1326a517a513eb06dd7779c421b112ea7c5dfe3a3ed899f950-filelists.xml.zck [Failed writing body (0 != 1600)]
[brent@brent-laptop ~]$ sudo dnf -y update
Fedora Modular 31 - x86_64 - Updates                                                                                                                                             44 kB/s |  17 kB     00:00    
Fedora Modular 31 - x86_64 - Updates                                                                                                                                            138 kB/s | 148 kB     00:01    
Error: Failed to download metadata for repo 'updates-modular': Yum repo downloading error: Downloading error: Unable to initialize zchunk file repodata/9f27d1117dcb5a1326a517a513eb06dd7779c421b112ea7c5dfe3a3ed899f950-filelists.xml.zck: Unable to set zchunk file descriptor for repodata/9f27d1117dcb5a1326a517a513eb06dd7779c421b112ea7c5dfe3a3ed899f950-filelists.xml.zck: Unable to find multipart download range

[mrb] $

Comment 1 Jaroslav Mracek 2020-01-14 16:30:12 UTC
Please could you provide a version of dnf, libdnf, librepo, rpm (`rpm -q dnf rpm librepo libdnf`)?

Comment 2 Brent R Brian 2020-01-14 18:01:16 UTC
The update went through (after a few hours??), but, 

dnf-4.2.17-1.fc31.noarch
rpm-4.15.1-1.fc31.x86_64
librepo-1.11.1-1.fc31.x86_64
libdnf-0.39.1-1.fc31.x86_64

Comment 3 Lukáš Hrázký 2020-01-17 13:59:22 UTC
Hello, Jonathan,

I've had a brief look at the code and it seems the data from Curl are written through a zchunk write callback. My assumption is this callback returns 0 instead of the correct number of bytes written. In such a case, it would appear it is some write error inside zchunk which should be handled and reported there, right?

Comment 4 Jonathan Dieter 2020-01-17 22:10:27 UTC
Lukáš, yes, it should be and I need to check whether the problem is that the error isn't being passed back up through the stack or whether zchunk isn't actually setting an error.  I'll try to get to that this weekend.

Brent, do you mind also giving the zchunk version (rpm -q zchunk-libs)?  Also, do you know if you were running low on disk space in your root partition when you got the error (df -h | grep ' /$')?

Comment 5 Brent R Brian 2020-01-18 15:52:04 UTC
zchunk-libs-1.1.4-1.fc31.x86_64 - the updates are working now - and this is the latest version

Comment 6 Jonathan Dieter 2020-01-18 21:51:24 UTC
Ok, I've done some testing and found a few places in librepo where we're not currently passing the zchunk error messages.  I've put up a PR to fix this, and am pushing zchunk-1.1.5 to make sure the messages zchunk sends aren't cryptic.

librepo PR: https://github.com/rpm-software-management/librepo/pull/181

Comment 7 Lukáš Hrázký 2020-01-20 10:10:03 UTC
Thanks, for that, Jonathan.

FTR, the bug isn't referenced in the commit message, so it won't be picked up automatically by our release system. I'll mark this as POST now and move it forward later on.

The reported problem was most likely local on the system and the improved error messages should help users diagnose it in the future.

Comment 8 Fedora Update System 2020-04-02 12:50:18 UTC
FEDORA-2020-d51dbe83a9 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-d51dbe83a9

Comment 9 Fedora Update System 2020-04-03 20:49:51 UTC
FEDORA-2020-d51dbe83a9 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-d51dbe83a9`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-d51dbe83a9

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2020-04-18 00:07:05 UTC
FEDORA-2020-d51dbe83a9 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.