Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1794161

Summary: Request to package gnucash for EPEL 8
Product: [Fedora] Fedora EPEL Reporter: Sean <rhbugsean>
Component: gnucashAssignee: Bill Nottingham <notting>
Status: ON_QA --- QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: epel8CC: notting, thewizard, yahoo
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Sean 2020-01-22 19:35:39 UTC
Hello, I want to kindly request the packaging of gnucash into EPEL 8.

Comment 1 John J. Egan 2020-06-21 19:16:15 UTC
I've been waiting for gnucash (I use it heavily) to show up in Epel8. Is there any hope for this?
Thank you.

Comment 2 Fedora Update System 2020-07-01 13:21:01 UTC
FEDORA-EPEL-2020-b1c000c190 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-b1c000c190

Comment 3 Fedora Update System 2020-07-02 01:27:57 UTC
FEDORA-EPEL-2020-b1c000c190 has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-b1c000c190

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 John J. Egan 2020-07-06 16:43:30 UTC
Missing package during attempted install:

"nothing provides perl(Finance::Quote) needed by gnucash-4.0-1.epel8.playground.x86_64"

Thank you.

Comment 5 Bill Nottingham 2020-07-06 19:51:35 UTC
-> https://bugzilla.redhat.com/show_bug.cgi?id=1811577

Comment 6 John J. Egan 2020-07-10 13:44:05 UTC
Things seem to be going downhill now:

$ sudo dnf install gnucash
Last metadata expiration check: 7:43:01 ago on Fri 10 Jul 2020 01:58:43 AM EDT.
Error: 
 Problem: conflicting requests
  - nothing provides libboost_date_time.so.1.69.0()(64bit) needed by gnucash-4.0-1.epel8.playground.x86_64
  - nothing provides libboost_filesystem.so.1.69.0()(64bit) needed by gnucash-4.0-1.epel8.playground.x86_64
  - nothing provides libboost_locale.so.1.69.0()(64bit) needed by gnucash-4.0-1.epel8.playground.x86_64
  - nothing provides libboost_program_options.so.1.69.0()(64bit) needed by gnucash-4.0-1.epel8.playground.x86_64
  - nothing provides libboost_regex.so.1.69.0()(64bit) needed by gnucash-4.0-1.epel8.playground.x86_64
  - nothing provides libboost_system.so.1.69.0()(64bit) needed by gnucash-4.0-1.epel8.playground.x86_64
  - nothing provides perl(Finance::Quote) needed by gnucash-4.0-1.epel8.playground.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Thank you.

Comment 7 Fedora Update System 2020-07-16 15:14:35 UTC
FEDORA-EPEL-2020-b1c000c190 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-b1c000c190

Comment 8 Fedora Update System 2020-07-17 01:00:51 UTC
FEDORA-EPEL-2020-b1c000c190 has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-b1c000c190

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2020-07-28 17:27:13 UTC
FEDORA-EPEL-2020-b1c000c190 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-b1c000c190

Comment 10 Fedora Update System 2020-07-30 18:57:53 UTC
FEDORA-EPEL-2020-b1c000c190 has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-b1c000c190

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2020-08-07 00:06:18 UTC
FEDORA-EPEL-2020-b1c000c190 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-b1c000c190

Comment 12 Fedora Update System 2020-08-07 01:27:37 UTC
FEDORA-EPEL-2020-b1c000c190 has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-b1c000c190

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 John J. Egan 2020-08-24 15:54:33 UTC
Any update on this? - today's attempt:

 sudo dnf install gnucash
Last metadata expiration check: 0:12:22 ago on Mon 24 Aug 2020 11:39:41 AM EDT.
Error: 
 Problem: conflicting requests
  - nothing provides libboost_date_time.so.1.69.0()(64bit) needed by gnucash-4.1-1.epel8.playground.x86_64
  - nothing provides libboost_filesystem.so.1.69.0()(64bit) needed by gnucash-4.1-1.epel8.playground.x86_64
  - nothing provides libboost_locale.so.1.69.0()(64bit) needed by gnucash-4.1-1.epel8.playground.x86_64
  - nothing provides libboost_program_options.so.1.69.0()(64bit) needed by gnucash-4.1-1.epel8.playground.x86_64
  - nothing provides libboost_regex.so.1.69.0()(64bit) needed by gnucash-4.1-1.epel8.playground.x86_64
  - nothing provides libboost_system.so.1.69.0()(64bit) needed by gnucash-4.1-1.epel8.playground.x86_64
  - nothing provides perl(Finance::Quote) needed by gnucash-4.1-1.epel8.playground.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Thank you.

Comment 14 Fedora Update System 2020-08-26 16:46:17 UTC
FEDORA-EPEL-2020-b1c000c190 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-b1c000c190

Comment 15 Fedora Update System 2020-08-27 15:08:25 UTC
FEDORA-EPEL-2020-b1c000c190 has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-b1c000c190

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 John J. Egan 2020-12-02 20:24:58 UTC
Clearly, I don't understand this process. After all of the above, I am still unable to install gnucash in CentOS 8. I just tried again:

$ sudo dnf install gnucash
Last metadata expiration check: 0:18:15 ago on Wed 02 Dec 2020 02:41:50 PM EST.
Error: 
 Problem: conflicting requests
  - nothing provides perl(Finance::Quote) needed by gnucash-4.1-2.epel8.playground.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

1. What don't I get/understand?
2. Will the day ever come that the command will actually install gnucash on my updated CentOS 8 system(s)?
3. Is there another avenue I am supposed to undertake at this point?

Thank you so much.

Comment 17 John J. Egan 2021-04-18 16:55:28 UTC
I now have a couple RHEL 8.3 installations. I am still getting the error:

 Problem: conflicting requests
  - nothing provides perl(Finance::Quote) needed by gnucash-4.1-2.epel8.playground.x86_64

Given the decision regarding CentOS, I am trying to move on/plan and the only obstacle is the 'missing' gnucash ... because of the missing perl dependency. Is there any hope that gnucash will be working any time soon?

Thank you.