Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1796695

Summary: [RFE] ddclient: epel8 build request
Product: [Fedora] Fedora EPEL Reporter: Matt Roddy <matt.roddy>
Component: ddclientAssignee: Scott Talbert <swt>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: epel8CC: dmach, i, james.antill, jrowens.fedora, matthewj.gear, swt, thomas
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: ddclient-3.9.1-1.el8 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-03-24 10:01:56 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1797039    
Bug Blocks:    

Description Matt Roddy 2020-01-31 01:34:21 UTC
Description of problem:
No EPEL 8 package for ddclient

Version-Release number of selected component (if applicable):
8.0, 8.1

Steps to Reproduce:
1. dnf search ddclient

Actual results:
No matches found.

Expected results:
ddclient.noarch

Additional info:
The latest version of ddclient (3.9.1) doesn't run on RHEL/CentOS 8 because of a dependency on perl-Data-Validation-IP which is also not available in EPEL 8.  The previous version of ddclient (3.8.3) from EPEL 7 though runs just fine.  I manually installed it using ddclient-3.8.3-2.el7.noarch.rpm and it runs no problem on CentOS 8.1 1911.

rpm -ivh --nodeps ddclient-3.8.3-2.el7.noarch.rpm 
warning: ddclient-3.8.3-2.el7.noarch.rpm: Header V3 RSA/SHA256 Signature, key ID 352c64e5: NOKEY
Verifying...                          ################################# [100%]
Preparing...                          ################################# [100%]
Updating / installing...
   1:ddclient-3.8.3-2.el7             ################################# [100%]
[/usr/lib/tmpfiles.d/ddclient.conf:1] Line references path below legacy directory /var/run/, updating /var/run/ddclient → /run/ddclient; please update the tmpfiles.d/ drop-in file accordingly.

Comment 1 Daniel Mach 2020-01-31 07:39:05 UTC
I believe this request is unrelated to dnf.
Moving to EPEL, ddclient component.

Comment 2 Scott Talbert 2020-01-31 16:47:53 UTC
@Matt Roddy,

Unless I'm missing something, perl-Digest-SHA1 is also missing on EL8?

Comment 3 Matt Roddy 2020-01-31 17:18:32 UTC
Looks like perl-Digest-SHA is already there in AppStream:

[~]$ dnf info perl-Digest-SHA
Last metadata expiration check: 21:47:26 ago on Thu 30 Jan 2020 02:29:16 PM EST.
Installed Packages
Name         : perl-Digest-SHA
Epoch        : 1
Version      : 6.02
Release      : 1.el8
Architecture : x86_64
Size         : 113 k
Source       : perl-Digest-SHA-6.02-1.el8.src.rpm
Repository   : @System
From repo    : AppStream
Summary      : Perl extension for SHA-1/224/256/384/512
URL          : http://search.cpan.org/dist/Digest-SHA/
License      : GPL+ or Artistic
Description  : Digest::SHA is a complete implementation of the NIST Secure Hash
             : Standard. It gives Perl programmers a convenient way to calculate
             : SHA-1, SHA-224, SHA-256, SHA-384, SHA-512, SHA-512/224, and
             : SHA-512/256 message digests. The module can handle all types of
             : input, including partial-byte data.

Comment 4 Scott Talbert 2020-01-31 19:07:35 UTC
(In reply to Matt Roddy from comment #3)
> Looks like perl-Digest-SHA is already there in AppStream:

Yeah, I was just discovering that too, although I was using a RHEL system so I had to figure out how to enable CodeReady Builder.

I'd like to try to get Data-Validate added though so I can build the latest version.

Comment 5 Fedora Update System 2020-03-09 02:45:03 UTC
ddclient-3.9.1-1.el8, perl-Data-Validate-IP-0.27-11.el8 has been pushed to the Fedora EPEL 8 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-f451873417

Comment 6 Fedora Update System 2020-03-24 10:01:56 UTC
FEDORA-EPEL-2020-f451873417 has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 7 matthewj.gear 2020-05-29 03:12:40 UTC
Not sure if I should post here or in Fedora. Sorry my first post. Attempting to install ddclient still produces error even though perl-Digest-SHA is installed via AppStream:

dnf install ddclient

Last metadata expiration check: 0:21:26 ago on Thu 28 May 2020 10:40:58 PM EDT.
Error: 
 Problem: conflicting requests
  - nothing provides perl(Digest::SHA1) needed by ddclient-3.9.1-1.el8.noarch
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Comment 8 Scott Talbert 2020-05-29 12:58:55 UTC
(In reply to matthewj.gear from comment #7)
> Not sure if I should post here or in Fedora. Sorry my first post. Attempting
> to install ddclient still produces error even though perl-Digest-SHA is
> installed via AppStream:
> 
> dnf install ddclient
> 
> Last metadata expiration check: 0:21:26 ago on Thu 28 May 2020 10:40:58 PM
> EDT.
> Error: 
>  Problem: conflicting requests
>   - nothing provides perl(Digest::SHA1) needed by ddclient-3.9.1-1.el8.noarch
> (try to add '--skip-broken' to skip uninstallable packages or '--nobest' to
> use not only best candidate packages)

Sorry, the discussion above was somewhat confusing.  You need to have the *PowerTools* repository enabled and the package needed is perl-Digest-SHA1 *not* perl-Digest-SHA.

Comment 9 matthewj.gear 2020-05-29 14:16:04 UTC
(In reply to Scott Talbert from comment #8)
> (In reply to matthewj.gear from comment #7)
> > Not sure if I should post here or in Fedora. Sorry my first post. Attempting
> > to install ddclient still produces error even though perl-Digest-SHA is
> > installed via AppStream:
> > 
> > dnf install ddclient
> > 
> > Last metadata expiration check: 0:21:26 ago on Thu 28 May 2020 10:40:58 PM
> > EDT.
> > Error: 
> >  Problem: conflicting requests
> >   - nothing provides perl(Digest::SHA1) needed by ddclient-3.9.1-1.el8.noarch
> > (try to add '--skip-broken' to skip uninstallable packages or '--nobest' to
> > use not only best candidate packages)
> 
> Sorry, the discussion above was somewhat confusing.  You need to have the
> *PowerTools* repository enabled and the package needed is perl-Digest-SHA1
> *not* perl-Digest-SHA.

Thank you so much! That worked perfectly! Thank you so much for the response, and so quickly!