Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1799970

Summary: reflections: FTBFS in Fedora rawhide/f32
Product: [Fedora] Fedora Reporter: Fedora Release Engineering <releng>
Component: reflectionsAssignee: Ben Rosser <rosser.bjr>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: java-sig-commits, rosser.bjr
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-02-07 20:23:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1750908    
Attachments:
Description Flags
build.log
none
root.log
none
state.log none

Description Fedora Release Engineering 2020-02-06 19:45:19 UTC
reflections failed to build from source in Fedora rawhide/f32

https://koji.fedoraproject.org/koji/taskinfo?taskID=41321186


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
Please fix reflections at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
reflections will be orphaned. Before branching of Fedora 33,
reflections will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2020-02-06 19:45:21 UTC
Created attachment 1660583 [details]
build.log

Comment 2 Fedora Release Engineering 2020-02-06 19:45:23 UTC
Created attachment 1660584 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2020-02-06 19:45:24 UTC
Created attachment 1660585 [details]
state.log

Comment 4 Ben Rosser 2020-02-07 16:52:57 UTC
It looks like the problem here is that reflections depends on openjfx, which is broken because we got rid of gradle (I think?).

I'll investigate this and see if it's possible to get rid of that dependency-- and also update reflections to a newer version while I'm at it.

Comment 5 Ben Rosser 2020-02-07 20:22:05 UTC
I've fixed this; I updated to 0.9.12, which doesn't seem to (?) depend on openjfx, and rebuilt successfully. (All the tests passed!)

https://koji.fedoraproject.org/koji/taskinfo?taskID=41428919