Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at

Bug 180092

Summary: Review Request: NRPE - Monitoring agent for Nagios
Product: [Fedora] Fedora Reporter: Mike McGrath <imlinux>
Component: Package ReviewAssignee: Dennis Gilmore <dennis>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Package Reviews List <fedora-package-review>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: drees76, jose.p.oliveira.oss, rmo, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-12-06 04:23:44 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 163779    

Description Mike McGrath 2006-02-05 18:13:50 UTC
SRPM Name or Url:

Nrpe is a system daemon that will execute various Nagios plugins
locally on behalf of a remote (monitoring) host that uses the
check_nrpe plugin.  Various plugins that can be executed by the 
daemon are available at:

This package provides the core agent.

Comment 1 Mike McGrath 2006-03-05 17:20:20 UTC
Upstream has a newer version

Comment 2 Jochen Schmitt 2006-03-05 21:24:37 UTC
+ Local build worked fine.
+ Mock build wored fine.

- Missing SMP flags. If it doesn't build with it, please add a comment
  (wiki: PackagingGuidelines#parallelmake)
- %{?dist} missing.
- init script doesn't have a reload action.

Comment 3 Mike McGrath 2006-03-05 22:04:32 UTC

- Added %{?dist}
- Parallel build added and works.
- Added reload section (via HUP) to the init script

Comment 4 Jochen Schmitt 2006-03-06 18:25:53 UTC
+ Local build worked fine.
+ Mock build worked fine.

1. Please register a fixed uid on
and use it in your rpm. Please see:

Comment 5 Mike McGrath 2006-03-06 18:58:03 UTC
"Using 'fedora-usermgmt' is optional and not required by packaging guidelines."

Comment 6 Jochen Schmitt 2006-03-12 19:38:12 UTC
Yes, put you should assign a fixed uid to the user which will created by your

Comment 7 Mike McGrath 2006-03-12 22:21:19 UTC
Sorry, I think I'm missing something.  I don't see in the packaging guidelines
nor in the review checklist a UID registration requirement.  I have thought
about switching this to the "damon" user.  Perhaps I should do that?

Comment 8 Paul Howarth 2006-03-13 08:53:53 UTC
(In reply to comment #7)
> Sorry, I think I'm missing something.  I don't see in the packaging guidelines
> nor in the review checklist a UID registration requirement.  I have thought
> about switching this to the "damon" user.  Perhaps I should do that?

There is no requirement to register or assign a fixed UID. Doing so only makes
sense for applications that may share data over NFS or a similar arrangement
that uses the same UIDs on multiple machines.

There are many packages in Extras that create users but do not assign fixed UIDs
(or attempt to do so using fedora-usermgmt).

I don't think reusing a different UID (did you mean "daemon"?) is a good idea

Can't say more without looking at the spec, and is unreachable from
here at the moment.

Comment 9 Mike McGrath 2006-03-13 14:31:44 UTC should be back up now.  Terrible storm blew through central
Illinois last night.  I did mean daemon but will stick with useradd -r nrpe in
my spec file.  I don't really even know what services use daemon.

Comment 10 Paul Howarth 2006-03-13 14:56:35 UTC
(In reply to comment #9)
> should be back up now.  Terrible storm blew through central
> Illinois last night.  I did mean daemon but will stick with useradd -r nrpe in
> my spec file.

Looks reasonable to me. I'd just add a '-c "Description of what account is for"'
option to the useradd command so that people will know what the nrpe account in
their passwd file is for.

Comment 11 Mike McGrath 2006-03-13 15:11:14 UTC

Updated useradd with a -c

Comment 12 Jochen Schmitt 2006-03-13 15:42:27 UTC

- You don't allocate a fixed uid/gid.

Comment 13 Jochen Schmitt 2006-03-13 15:43:07 UTC

- You don't allocate a fixed uid/gid.

Comment 14 Paul Howarth 2006-03-13 15:54:18 UTC
Looks like you need a new reviewer Mike, unless Jochen can justify his
requirement for a fixed uid/gid.

Comment 15 Ralf Corsepius 2006-03-13 15:59:21 UTC
(In reply to comment #13)
> Bad:
> - You don't allocate a fixed uid/gid.
Elaborate in depth why this package requires a fixed uid/gid.

Comment 17 Ralf Corsepius 2006-03-15 17:28:50 UTC
(In reply to comment #16)
> Please read:

This answer of yours is simply inacceptable.

Comment 18 Mike McGrath 2006-03-15 17:57:24 UTC
A) Fedora User Managment is optionsl
B) Removing users after removing a package is bad.  Notice NRPE does not remove
the user.  This prevents other people from becoming that user.   Many packages
(including httpd) don't remove the user they create when they get uninstalled.

Comment 19 Jochen Schmitt 2006-03-26 19:31:58 UTC
But nobody prohihed root for deleting such an user.

It may be right, that in older package the system user didn't assigned to a 
fixed user if, but this is from by point of view an argument for new packages.

Comment 20 Mike McGrath 2006-03-26 20:53:27 UTC
Thats fine, but its not required for Fedora Extras packages.  If you'd like to
make it a requirement you'll have to convince the FESCo to make it manditory. 
In the meantime its optional and not in the review guidelines anywhere.

Comment 22 Mike McGrath 2006-06-15 00:14:35 UTC
Last comment from Warren (Due to bz db loss)

During configure:

checking for Kerberos include files... could not find include files

Comment 23 Mike McGrath 2006-06-18 22:15:37 UTC

- Added --with-kerberos-inc to configure

Comment 24 Jose Pedro Oliveira 2006-06-24 13:32:17 UTC

Could you update to version 2.5.1 ?


Comment 25 Mike McGrath 2006-07-03 19:43:00 UTC

Sorry for the delay, here's 2.5.2-1

Comment 26 Jochen Schmitt 2006-07-06 18:44:56 UTC
+ Local build works fine.
+ Mock build works fine.
+ rpmlint quite on binary rpm.

- rpmlint complaints the binary rpm:
E: nrpe configure-without-libdir-spec
- Can't sheck source tarball agains upstream during a technical problem on
download the upstream source.

Comment 27 Mike McGrath 2006-07-07 14:06:59 UTC
The RPM lint error is safe to ignore because there is nothing that would go in a
lib dir.

Comment 28 Mike McGrath 2006-07-23 22:55:05 UTC
No more rpmlint errors:


Comment 29 Jose Pedro Oliveira 2006-08-01 01:15:24 UTC
I've found two more problems:

* missing build requirement: tcp_wrappers

  configure output
  checking for socket in -lsocket... no
  checking for main in -lwrap... yes
  checking for strdup... yes

  nrpe linking
  gcc ... -o nrpe nrpe.c utils.c -L/usr/lib  -lssl -lcrypto -lnsl -lwrap

* package nagios-plugins-nrpe shouldn't own 
  as they are owned by the nagios-plugins package (which is listed as a

     $ rpm -qf /usr/lib/nagios

     $ rpm -qf /usr/lib/nagios/plugins


Comment 30 Enrico Scholz 2006-08-25 06:23:44 UTC

* should not require nagios-plugins; see bug #203689

Comment 31 Mike McGrath 2006-08-25 14:43:59 UTC
This is by no means blocked.  The comments listed in 203689 are not required in
the packaging guidelines anywhere (that I found anyway)  If I'm mistaken please
let me know.

Comment 32 Mike McGrath 2006-08-25 14:52:19 UTC
Sorry, I thought I posted these:


- no longer owns libdir/nagios
- buildrequires tcp_wrappers

Comment 33 Dennis Gilmore 2006-10-19 15:13:50 UTC
ill take this over

Comment 34 Dennis Gilmore 2006-11-20 03:14:31 UTC
package meets naming and packaging guidelines.
 specfile is properly named, is cleanly written and uses macros consistently.
 dist tag is present.
 build root is correct.
      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 license field matches the actual license.
 license is open source-compatible. GPL License text is not included in 
 source files match upstream:
     22afa197db8e4e5b13fac48636917b6d  ../SOURCES/nrpe-2.5.2.tar.gz
     22afa197db8e4e5b13fac48636917b6d  nrpe-2.5.2.tar.gz
 latest version is being packaged.
 BuildRequires are proper.
 package builds in mock ( fc5,fc6,devel on x86_64 and i386 ).
 rpmlint is silent.
 final provides and requires are sane:
nagios-plugins-nrpe = 2.5.2-3.fc6

config(nrpe) = 2.5.2-3.fc6
nrpe = 2.5.2-3.fc6
config(nrpe) = 2.5.2-3.fc6
 no shared libraries are present.
 package is not relocatable.
 owns the directories it creates.
 doesn't own any directories it shouldn't.
 no duplicates in %files.
 file permissions are appropriate.
 %clean is present.
 code, not content.
 documentation is small, so no -docs subpackage is necessary.
 %docs are not necessary for the proper functioning of the package.
 no headers.
 no pkgconfig files.
 no libtool .la droppings.
 not a GUI app.
 not a web app.


Comment 35 Kevin Fenzi 2006-12-06 03:40:47 UTC
Hey Mike. 

I don't see this package in owners.list. Can you please add it?


Comment 36 Mike McGrath 2006-12-06 04:23:44 UTC
I'm terrible about that, its added now.  Also imported and build.  Closing bug.

Comment 37 Jose Pedro Oliveira 2006-12-08 17:17:39 UTC

Could you also build it for FC-5 and FC-6 ?


Comment 38 Mike McGrath 2006-12-08 17:36:39 UTC
Sure thing, I'll have them built by tonight.  Should be on the mirrors in the
next couple of days.