Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1804433

Summary: Print to File Dialog File Name edit accepts only text copied from Firefox itself. Not from external applications.
Product: [Fedora] Fedora Reporter: MarkV <mwizard>
Component: firefoxAssignee: Gecko Maintainer <gecko-bugs-nobody>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 32CC: 0xalen+redhat, anto.trande, elxreno, gecko-bugs-nobody, jhorak, john.j5live, kengert, pjasicek, rhughes, rstrode, sandmann, stransky
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-05-06 11:24:57 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1054334    

Description MarkV 2020-02-18 19:58:13 UTC
Description of problem:

After upgrading from Fedora 30 to 31, Firefox showed two problems.   This is one of them.  

I use the print dialog of FF to save files of web pages rather than sending them to the printer.  This seems to save web site pages into PDF files.

I need text copied by another application to the clipboard to also paste into the Print to File file name edit control.



How reproducible:


Steps to Reproduce:
1. Open a text editor and paste any random text you feel like so long as it is valid for a file name.
2. Open the FF browser and browse to any site you wish.
3. Click the File -> Print (Ctl-P)  to print the page.
4. Select Print to file.
5. Click the file control to bring up the file name dialog.  
6. Move to the text editor and select the random text you typed in step 1.  Select all the text and copy it to the clipboard.
7. Back to FF and try to paste the text into the file name of the dialog.  *It does nothing on my system.*
8. If you close the print dialog (no need to print anything) then select some text on the web page you are trying to print.  
9. Now click the File -> Print menu again to bring up the print dialog.
10. Select Print To File again.   
11. Now try to past the text from the web page into the file name control.  It works on my system.

Actual results:
Nothing happens.

Expected results:
I'm expecting the text from the clipboard to be pasted into the file name edit box of the print to file dialog.

Additional info:
I disabled all my add-ons and the problem persists.

Comment 1 MarkV 2020-02-18 20:00:34 UTC
I meant to say 'type' any random text into your text editor so long as its a valid file name.

Comment 2 MarkV 2020-05-06 03:39:23 UTC
The problem persists even after I've upgraded to FC32.

Using FC32 "Text Editor" does not exhibit this problem.

Comment 3 Martin Stransky 2020-05-06 08:49:33 UTC
It's perhaps because we use gtk_dialog_run() which runs nested main event loop which does not handle our clipboard code.

Comment 4 Martin Stransky 2020-05-06 11:24:57 UTC
Moved upstream - https://bugzilla.mozilla.org/show_bug.cgi?id=1635718