Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1806102

Summary: No sound after upgrading to 5.5.5 sof-audio-pci
Product: [Fedora] Fedora Reporter: Gustaf Andersson <gustaf>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 31CC: airlied, bskeggs, hdegoede, ichavero, itamar, jarodwilson, jeremy, jglisse, john.j5live, jonathan, josef, kernel-maint, linville, masami256, mchehab, mjg59, steved
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: ---
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-02-22 06:41:01 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
kernel log 5.5.5-200 none

Description Gustaf Andersson 2020-02-22 06:22:55 UTC
Created attachment 1664914 [details]
kernel log 5.5.5-200

1. Please describe the problem:

No sound after upgrading to the new kernel 5.5.5-200.fc31.x86_64 on a standard Fedora 31 workstation installation. In gnome sound panel it just registers a "Dummy output".

2. What is the Version-Release number of the kernel:

5.5.5-200.fc31.x86_64


3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :

Sound worked but not microphone.


4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:

Run on a lenovo yoga s740 laptop. Boot kernel > 5.4.20


5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:

Yes.


6. Are you running any modules that not shipped with directly Fedora's kernel?:

No.

7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

Comment 1 Gustaf Andersson 2020-02-22 06:41:01 UTC
I read this: https://github.com/thesofproject/sof/issues/2264

and found this: https://bugzilla.redhat.com/show_bug.cgi?id=1772498

So this is probably a duplicate of that. Sorry.

*** This bug has been marked as a duplicate of bug 1772498 ***