Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1811528

Summary: Request EPEL8 build of lightdm-gtk
Product: [Fedora] Fedora EPEL Reporter: Greg Bailey <gbailey>
Component: lightdm-gtkAssignee: Troy Dawson <tdawson>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: epel8CC: alt-gtk-de-sig, christoph.wickert, comes, email, lupinix.fedora, rdieter, tdawson, thomas.oulevey
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: lightdm-gtk-2.0.8-3.el8 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-05-20 00:38:43 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
patches required to build lightdm-gtk 1.8.5 for EPEL8 none

Description Greg Bailey 2020-03-09 06:49:40 UTC
Description of problem:

Request for EPEL8 branch and build for lightdm-gtk.

Version-Release number of selected component (if applicable):

2.0.6 or current

How reproducible:

N/A

Steps to Reproduce:
1.  CentOS 8 system w/ EPEL repo enabled
2.  dnf install lightdm-gtk
3.

Actual results:

no package found.

Expected results:

an available package...  :-)

Additional info:

I'm a Fedora packager but primarily use EPEL repositories, and can be a co-maintainer if that's helpful.

Comment 1 comes 2020-03-23 21:01:00 UTC
Created attachment 1672806 [details]
patches required to build lightdm-gtk 1.8.5 for EPEL8

A couple of patches needed to build for EPEL 8 lightdm-gtk 1.8.5 src.rpm from EPEL7

Comment 2 Christian Dersch 2020-07-20 10:29:39 UTC
I'd like to see that package in EPEL8, too. I can maintain it for EPEL8 if you don't want to struggle with that.

Comment 3 Thomas Oulevey 2021-08-18 12:52:33 UTC
Is there a blocker for that package ? Can I help ?

Comment 4 Troy Dawson 2022-04-28 19:46:25 UTC
The package from Fedora rawhide (lightdm-gtk-2.0.8-3.fc36) builds just fine, and installs on epel8.
Also, lightdm has already been built for epel8, but is not installable, because it requires lightdm-gtk.

There has already been two people saying they will maintain it in epel8.  I will be a third.
If you do not wish to maintain lightdm-gtk in epel9,
or do not think you will be able to do this in a timely manner,
I would be happy to be a co-maintainer of the package. (FES: tdawson)
Please add me through https://src.fedoraproject.org/rpms/lightdm-gtk/adduser

Comment 5 Fedora Update System 2022-05-11 19:14:12 UTC
FEDORA-EPEL-2022-6a75144b91 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-6a75144b91

Comment 6 Troy Dawson 2022-05-11 19:16:07 UTC
I have received commit permission.  I will build and maintain this package.

Comment 7 Fedora Update System 2022-05-12 02:12:42 UTC
FEDORA-EPEL-2022-6a75144b91 has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-6a75144b91

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2022-05-20 00:38:43 UTC
FEDORA-EPEL-2022-6a75144b91 has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.