Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at

Bug 1814872

Summary: Lenovo T450s Touchpad barely works
Product: [Fedora] Fedora Reporter: maztaim
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 32CC: airlied, awilliam, bskeggs, btissoir, gmarr, hdegoede, ichavero, itamar, jadahl, jarodwilson, jeremy, jglisse, john.j5live, jonathan, josef, kernel-maint, linville, masami256, mchehab, mjg59, peter.hutterer, steved, tpopela
Target Milestone: ---Flags: tpopela: fedora_prioritized_bug?
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: AcceptedFreezeException
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-04-04 01:51:08 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1705306    
Description Flags
debug-events using one finger
debug-events using two fingers
recorded with one finger
recorded with two fingers
Fixed up patch from comment 8 none

Description maztaim 2020-03-18 21:17:01 UTC
Description of problem:
Pointer barely moves when I use one finger on the touchpad.  Works a little better with two, but still unusable.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.  Attempt to use the touchpad with one finger.
2.  Attempt to use the touchpad with two fingers.

Actual results:
Pointer does nothing or little movement.

Expected results:
Pointer moves smoothly.

Additional info:
I'm going to follow for what I assume is helpful information in further comments.

Comment 1 maztaim 2020-03-18 21:18:16 UTC
Created attachment 1671230 [details]
debug-events using one finger

Comment 2 maztaim 2020-03-18 21:18:45 UTC
Created attachment 1671231 [details]
debug-events using two fingers

Comment 3 maztaim 2020-03-18 21:19:10 UTC
Created attachment 1671232 [details]
recorded with one finger

Comment 4 maztaim 2020-03-18 21:19:36 UTC
Created attachment 1671233 [details]
recorded with two fingers

Comment 5 maztaim 2020-03-18 21:22:58 UTC
# udevadm
Requires operation parameter.
[root@thelina ~]# udevadm info /sys/class/input/event9 
P: /devices/rmi4-00/input/input33/event9
N: input/event9
L: 0
E: DEVPATH=/devices/rmi4-00/input/input33/event9
E: DEVNAME=/dev/input/event9
E: ID_BUS=rmi
E: ID_SERIAL=noserial
E: LIBINPUT_DEVICE_GROUP=1d/6cb/0:rmi4-00

# cat /sys/class/dmi/id/modalias 

# touchpad-edge-detector 100x108 /dev/input/event9
Touchpad Synaptics TM3053-004 on /dev/input/event9
Move one finger around the touchpad to detect the actual edges
Kernel says:	x [0..1940], y [0..1062]
Touchpad sends:	x [562..1749], y [290..967] /^C[2147483647..-2147483648] |

Touchpad size as listed by the kernel: 97x53mm
User-specified touchpad size: 100x108mm
Calculated ranges: 1187/677

Suggested udev rule:
# <Laptop model description goes here>
evdev:name:Synaptics TM3053-004:dmi:bvnLENOVO:bvrJBET71WW(1.35):bd09/14/2018:svnLENOVO:pn20BXCTO1WW:pvrThinkPadT450s:rvnLENOVO:rn20BXCTO1WW:rvrSDK0E50512STD:cvnLENOVO:ct10:cvrNone:*

Comment 6 maztaim 2020-03-18 21:26:25 UTC
Of a note, this was working fine in Fedora 31.

Comment 7 Tomas Popela 2020-03-19 10:48:00 UTC
You can workaround it by suspending and resuming, then it the touchpad works normally.

Comment 8 Benjamin Tissoires 2020-03-19 10:48:52 UTC
there is a high chance it's a kernel issue that should be fixed by

Can you give a try to this kernel patch?

Comment 9 maztaim 2020-03-19 12:28:31 UTC
Suspending and resuming did not change how the touchpad worked for me.  I'll give the patch a try.

Comment 10 maztaim 2020-03-19 12:40:45 UTC
Before applying the patch, I did an update.  I am now running libinput-1.15.4-1.fc32.x86_64.  I am still seeing the same problem.

Comment 11 maztaim 2020-03-19 12:41:42 UTC
Still running kernel 5.6.0-0.rc5.git0.2.fc32.x86_64

Comment 12 maztaim 2020-03-19 14:57:20 UTC
Words are hard.  I read my comments like the patch didn't work.  Here's what I meant to write.

I tested the suspend/resume method.  It did not solve my problem.  I updated the system to latest.  That didn't change anything other than a newer version of libinput.  Still not working.

I am still in the process of building a kernel with the patch recommended.  I will report results after that.

Comment 13 maztaim 2020-03-19 17:48:12 UTC
I applied the patch suggested in comment 8.  Things seem to be back to normal.  The pointer moves, smoothly.  Left and right click works as expected, etc.

Comment 14 Benjamin Tissoires 2020-03-20 07:40:56 UTC
thanks for the testing. Seems like we should be all set with that patch. Re-assigning to the kernel

Comment 15 maztaim 2020-03-24 17:09:45 UTC
Created attachment 1673173 [details]
Fixed up patch from comment 8

I had to mangle the patch header to make it work.  Andrew Duggan did not have his e-mail set correctly at least as far as lkml was concerned.  This patch is what worked for me.  The code does not change, just the "header" information.

Comment 16 maztaim 2020-03-24 17:13:21 UTC
I am adding this because I want to test kernel-5.6.0-0.rc7.git0.2.fc32, but I don't believe it's in there.  I'm in the process of building a local kernel in case kernel-5.6.0-0.rc7.git0.2.fc32 doesn't work.

Comment 17 maztaim 2020-03-24 18:35:18 UTC
Tested kernel-5.6.0-0.rc7.git0.2.fc32.  Same issue as before.  I applied the patch I uploaded based on the patch mentioned in comment 6.  Everything works well again.

Comment 18 maztaim 2020-03-24 18:35:52 UTC
comment 8, not comment 6.

Comment 19 Tomas Popela 2020-03-27 11:36:49 UTC
Setting the fedora_prioritized_bug? to get this fixed for F32 final release. Without this change the touchpad on Lenovo T450s (and probably other models as well with the same touchpad) is barely usable. There is an upstream patch that was tested by maztaim that fixes the issue.

Comment 20 Fedora Blocker Bugs Application 2020-03-27 13:23:52 UTC
Proposed as a Freeze Exception for 32-final by Fedora user tpopela using the blocker tracking app because:

 Without this change the touchpad on Lenovo T450s (and probably other laptops as well with the same touchpad) is barely/not usable. There is an upstream patch that was tested by maztaim that fixes the issue.

Comment 21 Geoffrey Marr 2020-03-30 19:20:45 UTC
Discussed during the 2020-03-30 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedFreezeException" was made as this is a significant bug that makes use of a live image and initial installation difficult on affected systems, and those situations cannot be fixed with an update.


Comment 22 Fedora Update System 2020-03-30 19:55:57 UTC
FEDORA-2020-e8b6474ee5 has been submitted as an update to Fedora 32.

Comment 23 Hans de Goede 2020-03-30 20:01:58 UTC
*** Bug 1816968 has been marked as a duplicate of this bug. ***

Comment 24 maztaim 2020-03-30 20:56:15 UTC
Tested kernel from, kernel works.  Pointer moves as expected.  Also ran kernel regression test case found in update, both are PASS.

Comment 25 Fedora Update System 2020-03-31 01:52:37 UTC
FEDORA-2020-e8b6474ee5 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-e8b6474ee5`
You can provide feedback for this update here:

See also for more information on how to test updates.

Comment 26 Tomas Popela 2020-03-31 10:45:36 UTC
Fixes the issues with T450s touchpad for me.

Comment 27 Fedora Update System 2020-04-03 00:51:02 UTC
FEDORA-2020-e8b6474ee5 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 28 Adam Williamson 2020-04-04 01:51:08 UTC
Not sure why this wasn't closed automatically, but hey.