Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1823910

Summary: GNOME Contacts can't get past welcome screen
Product: [Fedora] Fedora Reporter: Daniel Rusek <drusek>
Component: gnome-contactsAssignee: Michael Catanzaro <mcatanza>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 32CC: awilliam, drusek, elad, fedoraparked, gnome-sig, kevin, mail, mcatanza, robatino
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedFreezeException
Fixed In Version: gnome-contacts-3.36-2.fc32 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-04-14 22:07:58 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1705305, 1705306    

Description Daniel Rusek 2020-04-14 19:06:37 UTC
Description of problem:
The latest version of GNOME Contacts can't get past welcome screen and is basically not working at all. This is caused by a regression that was already fixed upstream (see Additional info), but did not yet make it into Fedora.

Version-Release number of selected component (if applicable):
gnome-contacts-3.36-1.fc32.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1. Use latest, fully updated Fedora 32 Workstation Beta.
2. Launch "Contacts".
3. Click on "Local Address Book", then click on "Done".

Actual results:
GNOME Contacts can't get past welcome screen.

Expected results:
GNOME Contacts can get past welcome screen.

Additional info:
One line fix: https://gitlab.gnome.org/GNOME/gnome-contacts/-/commit/80c4ea3450912f24514437b7e70df1f0a03b114f

Comment 1 Fedora Blocker Bugs Application 2020-04-14 19:12:35 UTC
Proposed as a Freeze Exception for 32-final by Fedora user asciiwolf using the blocker tracking app because:

 GNOME Contacts that is a basic, preinstalled application on Fedora Workstation, cannot get past welcome screen (which makes the application basically not working at all) on Fedora 32. This is caused by a regression that was already fixed upstream by a simple, one line fix. This fix however did not make it into Fedora in time.

Comment 2 Adam Williamson 2020-04-14 19:48:28 UTC
I'd actually say this is a release blocker, per "All applications that can be launched using the standard graphical mechanism after a default installation of Fedora Workstation on the x86_64 architecture must start successfully and withstand a basic functionality test." If you can't get through the welcome wizard, you have no basic functionality.

I'm +1 blocker, +1 FE if for some reason others disagree on blocker status.

Comment 3 Kevin Fenzi 2020-04-14 19:50:07 UTC
+1 blocker, +1 FE

Comment 4 Ben Cotton 2020-04-14 19:51:00 UTC
+1 blocker, but I don't see this being an issue for Live images (in that it doesn't seem like an application that people would use without installing) so I'm also +1 for invoking the late blocker exception.

Comment 5 Stephen Gallagher 2020-04-14 19:53:03 UTC
I just loaded up GNOME Contacts (gnome-contacts-3.36-1.fc32.x86_64) for the first time and was presented with the welcome screen. It asked me to select my default contact list, I picked one of my Google Accounts. It worked fine after that.

Is it possible that this only affects the "local address book"?

As it is, I'm disinclined to call this a blocker. I'd +1 FE it, but I don't think it alone is worth holding up the release for.

Comment 6 Adam Williamson 2020-04-14 19:54:23 UTC
Stephen: looking at the fix, yeah, it seems entirely plausible it only affects the local store. I'm still +1, though, as that's clearly basic functionality.

Comment 7 Michael Catanzaro 2020-04-14 19:54:58 UTC
Doesn't matter honestly. If it's a one-line fix, then a FE is sufficient here.

Comment 8 Mohan Boddu 2020-04-14 19:57:00 UTC
As per the criteria in comment2 it might be a blocker, but I am definite +1 FE

Comment 9 Adam Williamson 2020-04-14 20:26:10 UTC
Marking at least accepted FE for now. A build is running ATM.

Comment 10 Fedora Update System 2020-04-14 20:42:21 UTC
FEDORA-2020-7953ad31e5 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-7953ad31e5

Comment 11 Fedora Update System 2020-04-14 21:05:45 UTC
FEDORA-FLATPAK-2020-718eb1c372 has been submitted as an update to Fedora 32 Flatpaks. https://bodhi.fedoraproject.org/updates/FEDORA-FLATPAK-2020-718eb1c372

Comment 12 Fedora Update System 2020-04-14 21:13:44 UTC
FEDORA-FLATPAK-2020-718eb1c372 has been pushed to the Fedora 32 Flatpaks testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-FLATPAK-2020-718eb1c372

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2020-04-14 21:45:29 UTC
FEDORA-FLATPAK-2020-718eb1c372 has been pushed to the Fedora 32 Flatpaks stable repository.
If problem still persists, please make note of it in this bug report.

Comment 14 Fedora Update System 2020-04-14 21:56:12 UTC
FEDORA-2020-7953ad31e5 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-7953ad31e5

Comment 15 Fedora Update System 2020-04-14 22:07:58 UTC
FEDORA-2020-7953ad31e5 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.