Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at

Bug 1824278

Summary: Firefox not adjusting to scaling on Wayland
Product: [Fedora] Fedora Reporter: Andy <andy>
Component: firefoxAssignee: Gecko Maintainer <gecko-bugs-nobody>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 31CC: 0xalen+redhat, anto.trande, elxreno, gecko-bugs-nobody, jhorak, john.j5live, kengert, pjasicek, rhughes, rstrode, sandmann, stransky
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-04-16 13:40:50 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1054334    
Description Flags
Firefox rendered too large after reducing scaling
Firefox rendered too small after scaling up none

Description Andy 2020-04-15 17:25:13 UTC
Created attachment 1679150 [details]
Firefox rendered too large after reducing scaling

Description of problem:

I have my internal screen set to 125% scaling. When I plug an external screen for which I set scaling to 100%, overall scaling is reset to 100%.

Whenever the scaling is changed by that means, Firefox's layout doesn't seem to follow. The window borders in Gnome's overwiew are correct, also mouse clicks seem to be caught correctly – but visually you only see part of the scaled-up Firefox UI, or it only takes ⅔ of the window and the rest is black.

See screenshot for a Gnome overview after setting scaling from 100% to 125% while Firefox was open.

Version-Release number of selected component (if applicable):
75.0 but I've seen the issue since upgrade to F31.

How reproducible:


Steps to Reproduce:

1. Open Firefox on Wayland.
2. Set increase screen scaling, f.e. from 100% to 125% or 200%
3. Open Gnome's overview (by pressing Super or clicking "Activities"

Actual results:

* Firefox' UI stays scaled, and is cut off.
* Inputs seem to be accepted in the right places (clicking top right somewhere will open the menu)

Expected results:

Also the UI scales after scaling changes

Additional info:
See screenshots

Comment 1 Andy 2020-04-15 17:25:51 UTC
Created attachment 1679151 [details]
Firefox rendered too small after scaling up

Comment 2 Martin Stransky 2020-04-15 21:35:20 UTC
Can you please try latest nightly under Wayland [1]?


Comment 3 Andy 2020-04-16 13:30:35 UTC
Hi Martin. Thanks for getting back to me.

This morning I tried using two screens with different scales, and dragging the window between the two screens is showing the issue as well.

I tried the latest nightly with Wayland backend, and everything's fine. Following that, I tried launching my installed Firefox with a clean profile, and it's fine as well.

So it must be some profile setting that is disturbing.

I remember setting some things to ensure Firefox uses hardware acceleration on my system, which might be the cause. I'll investigate.

Comment 4 Andy 2020-04-16 13:40:50 UTC
It seems to have been the combination of

- layers.acceleration.force-enabled
- gfx.webrender.all

that caused the issue.

I changed their defaults to fix some issues which I had with WebGL.


Comment 5 Andy 2020-05-20 13:29:14 UTC
Apparently another upgrade fixed it, it works now even with layers.acceleration.force-enabled active.