Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1831512

Summary: FTI: wingpanel: wingpanel
Product: [Fedora] Fedora Reporter: Igor Raits <igor.raits>
Component: wingpanelAssignee: Fabio Valentini <decathorpe>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 33CC: decathorpe
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-08-30 05:36:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1865624    
Bug Blocks: 1803235    

Description Igor Raits 2020-05-05 06:23:05 UTC
Hello,

Your package (wingpanel) Fails To Install in Fedora 33:

---
can't install wingpanel-2.3.1-2.fc33.x86_64:
  - nothing provides libmutter-6.so.0()(64bit) needed by wingpanel-2.3.1-2.fc33.x86_64
  - nothing provides libmutter-clutter-6.so.0()(64bit) needed by wingpanel-2.3.1-2.fc33.x86_64
  - nothing provides libmutter-cogl-6.so.0()(64bit) needed by wingpanel-2.3.1-2.fc33.x86_64
---

According to a policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks if you won't reply to this bug.

Thanks!

Comment 1 Fabio Valentini 2020-05-05 18:01:56 UTC
This breakage happens almost with every fedora release ... because libmutter bumps its library name with almost every new version.

Every time I have to wait until upstream projects for gala, elementary-greeter, and wingpanel adapt to new library names, and often kinda invasive API changes.

So ... marking this bug as ASSIGNED, but I doubt that this will be fixed soon. For fedora 32, this was only fixed a few days before the final freeze.

Comment 2 Ben Cotton 2020-08-11 13:25:25 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 33 development cycle.
Changing version to 33.

Comment 3 Fabio Valentini 2020-08-23 18:29:42 UTC
Upstream issue:
https://github.com/elementary/wingpanel/issues/339

Comment 4 Igor Raits 2020-08-30 05:36:33 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (ignatenkobrain).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 33.

Thanks for taking care of it!