Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1851184

Summary: Totem failed to play video due to /lib64/libgomp.so.1: cannot allocate memory in static TLS block
Product: [Fedora] Fedora Reporter: Trung LE <trung.le>
Component: totemAssignee: Bastien Nocera <bnocera>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 32CC: bnocera, caillon+fedoraproject, cfergeau, gnome-sig, icq, john.j5live, mclasen, rhughes, rstrode, sandmann
Target Milestone: ---   
Target Release: ---   
Hardware: ppc64le   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-06-26 08:19:14 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Trung LE 2020-06-25 17:24:29 UTC
Description of problem:

Totem fail to load gstreamer plugins


Version-Release number of selected component (if applicable):

totem 3.34.1

How reproducible:


Steps to Reproduce:
1. totem
2. choose to play a video

Actual results:

- ** Message: 03:08:49.033: Missing plugin: gstreamer|1.0|totem|H.264 (High 4:4:4 Profile) decoder|decoder-video/x-h264, level=(string)4.2, profile=(string)high-4:4:4, interlace-mode=(string)progressive, chroma-format=(string)4:2:0, bit-depth-luma=(uint)8, bit-depth-chroma=(uint)8 (H.264 (High 4:4:4 Profile) decoder)


Expected results:

- Video clip play correctly


Additional info:

totem produces following output upon starting up:

```
(totem:14411): GStreamer-WARNING **: 03:08:48.987: Failed to load plugin '/usr/lib64/gstreamer-1.0/libgstlibav.so': /lib64/libgomp.so.1: cannot allocate memory in static TLS block

(totem:14411): GStreamer-WARNING **: 03:08:48.993: Failed to load plugin '/usr/lib64/gstreamer-1.0/libgstlibav.so': /lib64/libgomp.so.1: cannot allocate memory in static TLS block

(totem:14411): GStreamer-WARNING **: 03:08:48.997: Failed to load plugin '/usr/lib64/gstreamer-1.0/libgstlibav.so': /lib64/libgomp.so.1: cannot allocate memory in static TLS block
```

I manage to work-around this issue by explicitly declaring LD_PRELOAD:

$ LD_PRELOAD=libgomp.so.1 totem

Comment 1 Trung LE 2020-06-25 17:28:02 UTC
It's seems to me similar to https://github.com/weldr/lorax/pull/942

Comment 2 Bastien Nocera 2020-06-26 08:19:14 UTC
> (totem:14411): GStreamer-WARNING **: 03:08:48.987: Failed to load plugin '/usr/lib64/gstreamer-1.0/libgstlibav.so': /lib64/libgomp.so.1: cannot allocate memory in static TLS block

Seeing as the problem is when loading software which Fedora does not ship, and that there's a known glibc bug associated with this error message, marking as a duplicate.

*** This bug has been marked as a duplicate of bug 1722181 ***