Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1893123

Summary: wpa_suplicant not installed by default
Product: [Fedora] Fedora Reporter: Łukasz Posadowski <mail>
Component: wpa_supplicantAssignee: Lubomir Rintel <lkundrak>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: 33CC: bgalvani, blueowl, dcaratti, dcbw, lkundrak
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-03-26 12:23:49 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Łukasz Posadowski 2020-10-30 09:27:00 UTC
Hi everyone.

Description of problem:
Since I remember, wpa_supplicant is not installed by default using Fedora Server iso. I kind of get it on a typical server install, but the installer allows me to connect to wifi network and every single time this connection fails in Network Manager after install, with very cryptic message suggesting that NM is trying wrong network adapter. Journal is loggning about wpa_supplicant missing:
Couldn't initialize supplicant interface: Failed to D-Bus activate wpa_supplicant service
and that's the only (and thankfully rather obvious) clue to track the problem. Usually I just download wpa_supplicant rpm from one of the mirrors and install it from usb stick, since it has no non-installed dependencies.

Could wpa_supplicant be installed by default in Server spin?

Version-Release number of selected component (if applicable):
Fedora Server 33, 32, 31...

How reproducible:
Always.

Steps to Reproduce:
1. Connect to wifi in the installer.
2. Install Fedora Server.
3. Try to connect to wifi network using nmcli.

Actual results:
nmcli wifi connection fails.

Expected results:
Connection works.

Additional info:
I know it is not a big deal, but will save me (and maybe one other person) 10 minutes of time after installing Fedora Server, also known as "the best Fedora". :)

Comment 1 Davide Caratti 2020-10-30 09:36:37 UTC
(In reply to Łukasz Posadowski from comment #0)
> Hi everyone.
> 
> Description of problem:
> Since I remember, wpa_supplicant is not installed by default using Fedora
> Server iso. I kind of get it on a typical server install, but the installer
> allows me to connect to wifi network and every single time this connection
> fails in Network Manager after install, with very cryptic message suggesting
> that NM is trying wrong network adapter. Journal is loggning about
> wpa_supplicant missing:
> Couldn't initialize supplicant interface: Failed to D-Bus activate
> wpa_supplicant service
> and that's the only (and thankfully rather obvious) clue to track the
> problem. Usually I just download wpa_supplicant rpm from one of the mirrors
> and install it from usb stick, since it has no non-installed dependencies.
> 
> Could wpa_supplicant be installed by default in Server spin?
> 
> Version-Release number of selected component (if applicable):
> Fedora Server 33, 32, 31...
> 
> How reproducible:
> Always.
> 
> Steps to Reproduce:
> 1. Connect to wifi in the installer.
> 2. Install Fedora Server.
> 3. Try to connect to wifi network using nmcli.
> 
> Actual results:
> nmcli wifi connection fails.
> 
> Expected results:
> Connection works.
> 
> Additional info:
> I know it is not a big deal, but will save me (and maybe one other person)
> 10 minutes of time after installing Fedora Server, also known as "the best
> Fedora". :)

hello,

can you please check if iwd is installed?

thanks!
-- 
davide

Comment 2 Łukasz Posadowski 2020-10-30 10:32:44 UTC
If You mean ipmiutil package, than no.
thanks

Comment 3 Davide Caratti 2020-10-30 11:15:01 UTC
(In reply to Łukasz Posadowski from comment #2)
> If You mean ipmiutil package, than no.
> thanks

thanks, but I was really referring to iwd (see https://bugzilla.redhat.com/show_bug.cgi?id=1756488 and https://bugzilla.redhat.com/show_bug.cgi?id=1743585).

wpa_supplicart (or alternatively iwd) are installed as a dependency of the NetworkManager-wifi package. If your distro has NetworkManager-wifi, then either wpa_supplicant or iwd should be installed. Can you please provide the output of this command?

$ for p in NetworkManager-wifi iwd wpa_supplicant; do dnf info $p ; done

thanks!

-- 
davide

(In reply to Łukasz Posadowski from comment #0)
> I know it is not a big deal, but will save me (and maybe one other person)
> 10 minutes of time after installing Fedora Server, also known as "the best
> Fedora". :)

I think that Fedora Server should prefer wpa_supplicant instead of iwd, because wpa_supplicant also handles macsec and 802.1x connections over wired ethernet (but this has nothing to do with missing support of wifi :) ).

Comment 4 Łukasz Posadowski 2020-10-30 12:44:51 UTC
Here it is:

for p in NetworkManager-wifi iwd wpa_supplicant ; do sudo dnf info $p ; done
Last metadata expiration check: 4:21:39 ago on Fri 30 Oct 2020 09:20:43 AM CET.
Installed Packages
Name         : NetworkManager-wifi
Epoch        : 1
Version      : 1.26.2
Release      : 2.fc33
Architecture : x86_64
Size         : 224 k
Source       : NetworkManager-1.26.2-2.fc33.src.rpm
Repository   : @System
From repo    : anaconda
Summary      : Wifi plugin for NetworkManager
URL          : http://www.gnome.org/projects/NetworkManager/
License      : GPLv2+ and LGPLv2+
Description  : This package contains NetworkManager support for Wifi and OLPC devices.

Available Packages
Name         : NetworkManager-wifi
Epoch        : 1
Version      : 1.26.4
Release      : 1.fc33
Architecture : x86_64
Size         : 99 k
Source       : NetworkManager-1.26.4-1.fc33.src.rpm
Repository   : updates
Summary      : Wifi plugin for NetworkManager
URL          : http://www.gnome.org/projects/NetworkManager/
License      : GPLv2+ and LGPLv2+
Description  : This package contains NetworkManager support for Wifi and OLPC devices.

Last metadata expiration check: 4:21:41 ago on Fri 30 Oct 2020 09:20:43 AM CET.
Installed Packages
Name         : iwd
Version      : 1.9
Release      : 1.fc33
Architecture : x86_64
Size         : 1.7 M
Source       : iwd-1.9-1.fc33.src.rpm
Repository   : @System
From repo    : anaconda
Summary      : Wireless daemon for Linux
URL          : https://git.kernel.org/pub/scm/network/wireless/iwd.git/
License      : LGPLv2+
Description  : The daemon and utilities for controlling and configuring the Wi-Fi network
             : hardware.

Last metadata expiration check: 4:21:44 ago on Fri 30 Oct 2020 09:20:43 AM CET.
Installed Packages
Name         : wpa_supplicant
Epoch        : 1
Version      : 2.9
Release      : 6.fc33
Architecture : x86_64
Size         : 5.3 M
Source       : wpa_supplicant-2.9-6.fc33.src.rpm
Repository   : @System
Summary      : WPA/WPA2/IEEE 802.1X Supplicant
URL          : http://w1.fi/wpa_supplicant/
License      : BSD
Description  : wpa_supplicant is a WPA Supplicant for Linux, BSD and Windows with support
             : for WPA and WPA2 (IEEE 802.11i / RSN). Supplicant is the IEEE 802.1X/WPA
             : component that is used in the client stations. It implements key negotiation
             : with a WPA Authenticator and it controls the roaming and IEEE 802.11
             : authentication/association of the wlan driver.


wpa_suplicant was installed by "rpm -Uvh wpa[package-name-version].rpm". It seems that iwd was installed by Anaconda.

thanks

Comment 5 Łukasz Posadowski 2021-03-26 12:23:49 UTC
On Fedory 34 it is the same - wpa_supplicant is not installed by default. I'll guess it's just how it meant to be. :) Like I said, it's not a big deal, so I'm closing the bug for now.

Comment 6 Davide Caratti 2021-03-26 12:40:53 UTC
(In reply to Łukasz Posadowski from comment #5)
> On Fedory 34 it is the same - wpa_supplicant is not installed by default.
> I'll guess it's just how it meant to be. :) Like I said, it's not a big
> deal, so I'm closing the bug for now.

thanks Łukasz - I think that the problem is the inclusion of iwd "as-is". Unless the NetworkManager backend properly, i.e. editing /etc/NetworkManager/conf.d/nm.conf like written in [1], wifi will not be functional. I'm setting duplicate of bz1756488, that's currently assigned to the Anaconda team.

please let me know if you need additional information. Thanks!
-- 
davide

*** This bug has been marked as a duplicate of bug 1756488 ***