Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1894154

Summary: gdb doesn't suggest a debuginfo-install command
Product: Red Hat Developer Toolset Reporter: Keith Seitz <keiths>
Component: gdbAssignee: Keith Seitz <keiths>
Status: CLOSED ERRATA QA Contact: Martin Cermak <mcermak>
Severity: high Docs Contact:
Priority: unspecified    
Version: DTS 10.0 RHEL 7CC: dsmith, ego.cordatus, extras-qa, jan.kratochvil, keiths, kevinb, mcatanza, mcermak, mnewsome, ngompa13, ohudlick, palves, pmuldoon, sergiodj, sergio, yalterz
Target Milestone: alphaKeywords: Regression
Target Release: 9.1   
Hardware: x86_64   
OS: Unspecified   
Whiteboard:
Fixed In Version: devtoolset-10-gdb-9.2-9.el7 Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: 1887025
: 1894703 (view as bug list) Environment:
Last Closed: 2020-12-01 12:15:13 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1887025    
Bug Blocks: 1894703, 1915430    

Description Keith Seitz 2020-11-03 16:46:01 UTC
+++ This bug was initially created as a clone of Bug #1887025 +++

Description of problem:
In F33 gdb no longer suggests a debuginfo-install command, making getting good backtraces for crash reports very tedious.

Version-Release number of selected component (if applicable):
gdb-9.2-7.fc33.x86_64

How reproducible:
Always

Steps to Reproduce:
1. coredumpctl gdb after a crash or attach to something with gdb

Actual results:
No debuginfo-install suggested.

Expected results:
gdb suggests debuginfo-install like it used to.

--- Additional comment from Michael Catanzaro on 2020-11-02 17:21:21 UTC ---

Hi, any idea what has gone wrong here?

Could it be related to debuginfod? Or to LTO?

--- Additional comment from Keith Seitz on 2020-11-02 17:25:07 UTC ---

It's probably a rebase error or even the deubginfod backport. I will investigate.

--- Additional comment from Keith Seitz on 2020-11-02 21:03:10 UTC ---

Yeah, it's the debuginfod backport. New rawhide build coming.

While Kevin would prefer to rebase Fedora 33 to gdb-10.1, eliminating the offending patch
altogether, I think this important enough to warrant backporting.

--- Additional comment from Fedora Update System on 2020-11-02 21:33:05 UTC ---

FEDORA-2020-8b6eb54798 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-8b6eb54798

--- Additional comment from Sergio Basto on 2020-11-03 00:52:07 UTC ---

please see also https://bugzilla.redhat.com/show_bug.cgi?id=1874275

--- Additional comment from Fedora Update System on 2020-11-03 02:26:52 UTC ---

FEDORA-2020-8b6eb54798 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-8b6eb54798`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-8b6eb54798

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

--- Additional comment from Ivan Molodetskikh on 2020-11-03 07:27:35 UTC ---

I can't install it for some reason:

$ rpm -q gdb
gdb-9.2-7.fc33.x86_64
$ sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-8b6eb54798 
Last metadata expiration check: 0:00:08 ago on Вт 03 ноя 2020 10:27:00.
No security updates needed, but 147 updates available
Dependencies resolved.
Nothing to do.
Complete!

Comment 3 Keith Seitz 2020-11-03 19:37:38 UTC
QE: To test:

1. Install devtoolset-10-elfutils-debuginfod
  $ yum install -y devtoolset-10-elfutils-debuginfod

2. Download, e.g., coreutils and coreutils debuginfo rpms.
  $ mkdir distro-rpms; cd distro-rpms
  $ wget http://download.eng.bos.redhat.com/brewroot/vol/rhel-7/packages/coreutils/8.22/24.el7/x86_64/coreutils-8.22-24.el7.x86_64.rpm
  $ wget http://download.eng.bos.redhat.com/brewroot/vol/rhel-7/packages/coreutils/8.22/24.el7/x86_64/coreutils-debuginfo-8.22-24.el7.x86_64.rpm
  $ # or use yumdownloader or yum install --downloadonly

3. Start debuginfod
  distro-rpms$ scl enable devtoolset-10 /bin/bash
  distro-rpms$ debuginfod -R .

--- In another terminal:

1. Enable DTS10
  $ scl enable devtoolset-10 /bin/bash

2. Clear the debuginfod client cache
  $ rm -rf ~/.cache/debuginfod_client

3. Verify "missing" messages:
  $ unset DEBUGINFOD_URLS
  $ gdb -q /usr/bin/lReading symbols from /usr/bin/ls...
  Reading symbols from .gnu_debugdata for /usr/bin/ls...
  (No debugging symbols found in .gnu_debugdata for /usr/bin/ls)
  Missing separate debuginfos, use: debuginfo-install coreutils-8.22-24.el7.x86_64
  
  **NOTE** It is this last line that MUST be present

4. Verify debuginfod
  $ export DEBUGINFOD_URLS=http://localhost:8002/
  $ gdb -q /usr/bin/ls
  Reading symbols from /usr/bin/ls...
  Downloading separate debug info for /usr/bin/ls...
  Reading symbols from /home/rhel7/.cache/debuginfod_client/ceaf496f3aec08afced234f4f36330d3d13a657b/debuginfo...
  Downloading separate debug info for /home/rhel7/.cache/debuginfod_client/ceaf496f3aec08afced234f4f36330d3d13a657b/debuginfo...

**NOTE** The "Downloading ..." liones MUST be present

Comment 9 errata-xmlrpc 2020-12-01 12:15:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (new packages: devtoolset-10-gdb), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:5295