Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1897256

Summary: pybluez fails to build with Python 3.10: Py_TYPE= needs to be replaced with Py_SET_TYPE
Product: [Fedora] Fedora Reporter: Tomáš Hrnčiar <thrnciar>
Component: pybluezAssignee: Gwyn Ciesla <gwync>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: gwync, mhroncok, thrnciar, vstinner
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-11-12 16:48:56 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1890881    

Description Tomáš Hrnčiar 2020-11-12 16:02:26 UTC
pybluez fails to build with Python 3.10.0a2.

bluez/btmodule.c:2837:22: error: lvalue required as left operand of assignment
 2837 |  Py_TYPE(&sock_type) = &PyType_Type;
      |                      ^
bluez/btmodule.c:2838:29: error: lvalue required as left operand of assignment
 2838 |  Py_TYPE(&sdp_session_type) = &PyType_Type;
      |                             ^

https://docs.python.org/3.10/whatsnew/3.10.html#id2

Since Py_TYPE() is changed to the inline static function, Py_TYPE(obj) = new_type must be replaced with Py_SET_TYPE(obj, new_type): see Py_SET_TYPE() (available since Python 3.9). For backward compatibility, this macro can be used:

#if PY_VERSION_HEX < 0x030900A4
#  define Py_SET_TYPE(obj, type) ((Py_TYPE(obj) = (type)), (void)0)
#endif
https://bugs.python.org/issue39573

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01757238-pybluez/

For all our attempts to build pybluez with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/pybluez/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Gwyn Ciesla 2020-11-12 16:48:56 UTC
Patch sent upstream.

Comment 2 Miro Hrončok 2020-11-18 17:59:16 UTC
JFYI The change was reverted in Python 3.10, because it caused too much trouble (the amount of affected Fedora packages was too big).

This comment is mass posted in all relevant bugzillas. If you already worked upstream to fix the problem, you might want to let them know about the revert, but the new way of doing things also works.

Sorry for the trouble and thanks again for the fix.

https://github.com/python/cpython/commit/0e2ac21dd

Comment 3 Victor Stinner 2021-09-08 12:13:26 UTC
I proposed a fix for Python 3.11 (Py_TYPE is converted again to a static inline function): https://github.com/pybluez/pybluez/pull/410