Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1899998

Summary: Modular GNOME Keyring services
Product: [Fedora] Fedora Reporter: Ben Cotton <bcotton>
Component: Changes TrackingAssignee: Daiki Ueno <dueno>
Status: CLOSED DEFERRED QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: amoloney, awilliam, bberg, dev, dueno, thrcka
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2023-10-03 17:46:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Ben Cotton 2020-11-20 15:01:50 UTC
This is a tracking bug for Change: Modular GNOME Keyring services
For more details, see: https://fedoraproject.org/wiki/Changes/ModularGnomeKeyring

The monolithic daemon provided by GNOME Keyring will be split into dedicated sub-daemons, so that they can be consistently managed by systemd.

Comment 1 Ben Cotton 2021-02-10 21:58:00 UTC
We have reached the 'Code Complete (testable)' milestone in the Fedora 34 release cycle. If your Change is in a testable state, please set the status to MODIFIED. If this Change will not be ready for Fedora 34, please set the version to rawhide.

The 100% code complete deadline is Tue 2021-02-23.

Comment 2 Ben Cotton 2021-02-16 15:52:00 UTC
Reminder: The change complete (100% complete) deadline for Fedora 34 changes is Tuesday 23 February. At that point, changes should be 100% code complete, along with supporting documentation where appropriate. Please indicate this by setting the tracker bug for your change to ON_QA.

Comment 3 Daiki Ueno 2021-02-17 15:23:05 UTC
I'm afraid this change most likely will not be complete by the Fedora 34 deadline. Although the relevant changes are likely to be included as part of the GNOME 40 update, the actual enablement of the feature (e.g., systemd preset, default user configuration such as envvars) would need more discussion among other DEs. Can we retarget it to Fedora 35?

The upstream discussion is ongoing at: https://gitlab.gnome.org/GNOME/gcr/-/merge_requests/67

Comment 4 Ben Cotton 2021-02-17 15:40:23 UTC
(In reply to Daiki Ueno from comment #3)
>  Can we retarget it to Fedora 35?

Will do! I'll update the trackers. You don't need to re-submit the proposal.

Comment 5 Ben Cotton 2021-08-10 12:32:47 UTC
Today is the "Code complete (testable)" deadline in the Fedora Linux 35 release schedule:
https://fedorapeople.org/groups/schedule/f-35/f-35-key-tasks.html

If this Change is complete enough to be tested, please indicate this by setting this bug to the MODIFIED status. (If it is 100% complete, you can set it to ON_QA).

If you wish to defer this Change to Fedora Linux 36, please needinfo bcotton.

Comment 6 Daiki Ueno 2021-08-10 12:39:21 UTC
Sorry, I haven't had time to move this forward in this cycle as well; could you defer it to Fedora Linux 36?

Comment 7 Ben Cotton 2021-08-10 17:05:01 UTC
Done!

Comment 8 Ben Cotton 2022-02-08 21:07:58 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 36 development cycle.
Changing version to 36.

Comment 9 Ben Cotton 2022-02-08 21:15:06 UTC
Today we reached the Code Complete (testable) milestone in the F36 schedule: https://fedorapeople.org/groups/schedule/f-36/f-36-key-tasks.html

All code for this change should be complete enough for testing. You can indicate this by setting the bug status to MODIFIED. (If the code is fully complete, you can go ahead and set it to ON_QA.)

If you need to defer this Change to F37, please needinfo bcotton.

Comment 10 Daiki Ueno 2022-02-10 15:59:30 UTC
Sorry, we have to defer this to the next release again. Could you move it?

Comment 11 Ben Cotton 2022-08-09 16:02:52 UTC
Today we reached the Code Complete (Testable) milestone on the F37 schedule: https://fedorapeople.org/groups/schedule/f-37/f-37-key-tasks.html

At this time, all F37 Changes should be complete enough to be testable. You can indicate this by setting this tracker to the MODIFIED status. If the Change is 100% code complete, you can set the tracker to ON_QA. If you need to defer this Change to F38, please NEEDINFO me.

Changes that have not reached at least the MODIFIED status will be given to FESCo for evaluation of contingency plans.

Comment 12 Daiki Ueno 2022-08-11 01:33:12 UTC
Hello Ben, I need to defer this once again to F38. Hopefully we'll have time to complete this during that cycle.

Comment 13 Ben Cotton 2022-08-11 12:21:58 UTC
Done, thanks for the update!

Comment 14 Ben Cotton 2023-02-07 14:27:33 UTC
Today we reached the Code Complete (Testable) milestone on the F38 schedule: https://fedorapeople.org/groups/schedule/f-38/f-38-key-tasks.html

At this time, all F38 Changes should be complete enough to be testable. You can indicate this by setting this tracker to the MODIFIED status. If the Change is 100% code complete, you can set the tracker to ON_QA. If you need to defer this Change to F39, please NEEDINFO me.

Changes that have not reached at least the MODIFIED status will be given to FESCo for evaluation of contingency plans.

Comment 15 Daiki Ueno 2023-02-13 06:23:02 UTC
Hello Ben, please defer this to F39.

Comment 16 Ben Cotton 2023-02-13 20:42:43 UTC
Paperwork filed!

Comment 17 Adam Williamson 2023-08-22 23:26:06 UTC
It looks like no work on this has been done yet for F39. We are past the Beta freeze, when it should have been 100% complete. Do we need to defer this to F40? Thanks!

Comment 18 Adam Williamson 2023-10-03 17:46:45 UTC
This Change is dropped, per https://pagure.io/fesco/issue/3059#comment-876796 . If interest in it ever revives, it can be re-proposed.

Comment 19 Red Hat Bugzilla 2024-02-01 04:25:02 UTC
The needinfo request[s] on this closed bug have been removed as they have been unresolved for 120 days