Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1905258

Summary: ghdl links against ligbnat-10 but libgnat-11 is already avaiable/installed
Product: [Fedora] Fedora Reporter: George R. Goffe <grgoffe>
Component: ghdlAssignee: Thomas Sailer <fedora>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: rawhideCC: dan, fedora
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-12-08 13:19:59 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description George R. Goffe 2020-12-07 21:20:47 UTC
Description of problem: Attempted upgrade of this system produced error messages related to dependencies (see below).


Version-Release number of selected component (if applicable):
ghdl-0.38~dev-9.20200827git4ce9925.fc34.x86_64. Requests libgnat-10 but libgnat-11 is already available.

How reproducible:
always

Steps to Reproduce:
1.see below
2.
3.

Actual results:
see below

Expected results:
successful system upgrade

Additional info:

dnf install libgnat'*' ghdl'*'
Last metadata expiration check: 0:00:08 ago on Mon 07 Dec 2020 01:12:17 PM PST.
Package libgnat-11.0.0-0.7.fc34.x86_64 is alghdl-0.38~dev-9.20200827git4ce9925.fc34.x86_64ready installed.
Package ghdl-grt-0.38~dev-9.20200827git4ce9925.fc34.x86_64 is already installed.
Error: 
 Problem 1: conflicting requests
  - nothing provides libgnat-10.so()(64bit) needed by ghdl-0.38~dev-9.20200827git4ce9925.fc34.x86_64
 Problem 2: conflicting requests
  - nothing provides libgnat-10.so()(64bit) needed by ghdl-llvm-0.38~dev-9.20200827git4ce9925.fc34.x86_64
 Problem 3: conflicting requests
  - nothing provides libgnat-10.so()(64bit) needed by ghdl-mcode-0.38~dev-9.20200827git4ce9925.fc34.x86_64
  - nothing provides libgnarl-10.so()(64bit) needed by ghdl-mcode-0.38~dev-9.20200827git4ce9925.fc34.x86_64
(try to add '--skip-broken' to skip uninstallable packages)

Comment 1 Dan HorĂ¡k 2020-12-08 13:19:59 UTC

*** This bug has been marked as a duplicate of bug 1905167 ***