Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1914840

Summary: python-osc-lib fails to build with Python 3.10: argparse output has changed
Product: [Fedora] Fedora Reporter: Tomáš Hrnčiar <thrnciar>
Component: python-osc-libAssignee: Alfredo Moralejo <amoralej>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: amoralej, apevec, jakub.ruzicka, jcapitao, jpena, karlthered, mhroncok, openstack-sig, thrnciar
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-06-17 16:18:54 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1913291, 1969012, 1969068, 1969077    
Bug Blocks: 1890881, 1926337, 1927309, 1927313, 1968952, 1968993, 1969000, 1969030, 1969049, 1969062, 1969067, 1969122, 1969124, 1969152, 1969177    

Description Tomáš Hrnčiar 2021-01-11 10:17:55 UTC
python-osc-lib fails to build with Python 3.10.0a4.

osc_lib.tests.utils.test_tags.TestTagHelps.test_add_tag_option_to_parser_for_unset
----------------------------------------------------------------------------------

Captured traceback:
~~~~~~~~~~~~~~~~~~~
    Traceback (most recent call last):
      File "/builddir/build/BUILD/osc-lib-2.2.1/osc_lib/tests/utils/test_tags.py", line 288, in test_add_tag_option_to_parser_for_unset
        self._test_tag_method_help(
      File "/builddir/build/BUILD/osc-lib-2.2.1/osc_lib/tests/utils/test_tags.py", line 191, in _test_tag_method_help
        self.assertEqual(exp_normal, parser.format_help())
      File "/usr/lib/python3.10/site-packages/testtools/testcase.py", line 391, in assertEqual
        self.assertThat(observed, matcher, message)
      File "/usr/lib/python3.10/site-packages/testtools/testcase.py", line 478, in assertThat
        raise mismatch_error
    testtools.matchers._impl.MismatchError: !=:
    reference = '''\
    usage: run.py [-h] [--tag <tag> | --all-tag]
    
    optional arguments:
      -h, --help   show this help message and exit
      --tag <tag>  Tag to be removed from the test (repeat option to remove
                   multiple tags)
      --all-tag    Clear all tags associated with the test
    '''
    actual    = '''\
    usage: run.py [-h] [--tag <tag> | --all-tag]
    
    options:
      -h, --help   show this help message and exit
      --tag <tag>  Tag to be removed from the test (repeat option to remove
                   multiple tags)
      --all-tag    Clear all tags associated with the test
    '''

Argparse output has changed from:


  optional arguments:


to:


  options:


https://bugs.python.org/issue9694
https://bugs.python.org/issue42870


For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01871069-python-osc-lib/

For all our attempts to build python-osc-lib with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-osc-lib/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Ben Cotton 2021-02-09 15:39:18 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 2 Miro Hrončok 2021-06-04 20:13:02 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 3 Miro Hrončok 2021-06-07 22:57:57 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 4 Miro Hrončok 2021-06-08 11:30:06 UTC
*** Bug 1969072 has been marked as a duplicate of this bug. ***

Comment 5 Miro Hrončok 2021-06-15 20:24:03 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 6 Alfredo Moralejo 2021-06-16 07:09:07 UTC
Blocked by eventlet