Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.

Bug 1926091

Summary: python-test_server fails to build with Python 3.10: ImportError: cannot import name 'Iterable' from 'collections'
Product: [Fedora] Fedora Reporter: Tomáš Hrnčiar <thrnciar>
Component: python-test_serverAssignee: Raphael Groner <projects.rg>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 35CC: gmarr, mhroncok, projects.rg, python-sig, thrnciar, tir.karthi
Target Milestone: ---Keywords: Patch, Reopened, Upstream
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedFreezeException
Fixed In Version: python-test_server-0.0.31-14.fc35 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-08-30 21:41:41 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1890881, 1891954, 1927309, 1927313    

Description Tomáš Hrnčiar 2021-02-08 07:46:40 UTC
python-test_server fails to build with Python 3.10.0a5.

==================================== ERRORS ====================================
_________________________ ERROR collecting test/bug.py _________________________
ImportError while importing test module '/builddir/build/BUILD/test_server-0.0.31/test/bug.py'.
Hint: make sure your test modules/packages have valid Python names.
Traceback:
/usr/lib64/python3.10/importlib/__init__.py:126: in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
test/bug.py:7: in <module>
    from test_server import WaitTimeoutError
test_server/__init__.py:1: in <module>
    from test_server.server import *  # noqa pylint: disable=wildcard-import
test_server/server.py:9: in <module>
    from collections import defaultdict, Iterable
E   ImportError: cannot import name 'Iterable' from 'collections' (/usr/lib64/python3.10/collections/__init__.py)
______________________ ERROR collecting test/callbacks.py ______________________
ImportError while importing test module '/builddir/build/BUILD/test_server-0.0.31/test/callbacks.py'.
Hint: make sure your test modules/packages have valid Python names.
Traceback:
/usr/lib64/python3.10/importlib/__init__.py:126: in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
test/callbacks.py:7: in <module>
    from .util import (# pylint: disable=unused-import
test/util.py:3: in <module>
    from test_server import TestServer
test_server/__init__.py:1: in <module>
    from test_server.server import *  # noqa pylint: disable=wildcard-import
test_server/server.py:9: in <module>
    from collections import defaultdict, Iterable
E   ImportError: cannot import name 'Iterable' from 'collections' (/usr/lib64/python3.10/collections/__init__.py)
_______________________ ERROR collecting test/server.py ________________________
ImportError while importing test module '/builddir/build/BUILD/test_server-0.0.31/test/server.py'.
Hint: make sure your test modules/packages have valid Python names.
Traceback:
/usr/lib64/python3.10/importlib/__init__.py:126: in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
test/server.py:15: in <module>
    from test_server import TestServer, WaitTimeoutError
test_server/__init__.py:1: in <module>
    from test_server.server import *  # noqa pylint: disable=wildcard-import
test_server/server.py:9: in <module>
    from collections import defaultdict, Iterable
E   ImportError: cannot import name 'Iterable' from 'collections' (/usr/lib64/python3.10/collections/__init__.py)
________________________ ERROR collecting test/util.py _________________________
ImportError while importing test module '/builddir/build/BUILD/test_server-0.0.31/test/util.py'.
Hint: make sure your test modules/packages have valid Python names.
Traceback:
/usr/lib64/python3.10/importlib/__init__.py:126: in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
test/util.py:3: in <module>
    from test_server import TestServer
test_server/__init__.py:1: in <module>
    from test_server.server import *  # noqa pylint: disable=wildcard-import
test_server/server.py:9: in <module>
    from collections import defaultdict, Iterable
E   ImportError: cannot import name 'Iterable' from 'collections' (/usr/lib64/python3.10/collections/__init__.py)
=========================== short test summary info ============================
ERROR test/bug.py
ERROR test/callbacks.py
ERROR test/server.py
ERROR test/util.py
!!!!!!!!!!!!!!!!!!! Interrupted: 4 errors during collection !!!!!!!!!!!!!!!!!!!!
============================== 4 errors in 0.41s ===============================

bpo-37324: Remove deprecated aliases to Collections Abstract Base Classes
from the collections module.

https://docs.python.org/3.10/whatsnew/changelog.html#python-3-10-0-alpha-5

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01952503-python-test_server/

For all our attempts to build python-test_server with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-test_server/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Ben Cotton 2021-02-09 16:05:59 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 2 Karthikeyan Singaravelan 2021-02-17 15:51:45 UTC
Upstream PR : https://github.com/lorien/test_server/pull/24

Comment 3 Raphael Groner 2021-02-17 16:44:22 UTC
*** Bug 1793021 has been marked as a duplicate of this bug. ***

Comment 4 Raphael Groner 2021-04-17 11:44:40 UTC
As Miro writes in bug #1793021 (duplication), the patch was reverted successfully for Python 3.9.0a4. Is that now a regression in Python 3.10.0a5?

Comment 5 Tomáš Hrnčiar 2021-04-19 06:24:00 UTC
Hello, yes, the change was postponed in Python 3.9. and is now present in Python 3.10.0a5+. See: https://github.com/python/cpython/commit/c47c78b878ff617164b2b94ff711a6103e781753

Comment 6 Raphael Groner 2021-04-19 08:51:28 UTC
Thanks, I'll try to rebuild with the proposed patch in pull request.
https://github.com/lorien/test_server/pull/24

Comment 7 Miro Hrončok 2021-06-04 20:15:52 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 8 Miro Hrončok 2021-06-07 23:00:13 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 9 Miro Hrončok 2021-06-08 11:34:41 UTC
*** Bug 1969155 has been marked as a duplicate of this bug. ***

Comment 10 Ben Cotton 2021-08-10 12:50:38 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 35 development cycle.
Changing version to 35.

Comment 11 Miro Hrončok 2021-08-23 11:55:38 UTC
Raphael, could you backport https://github.com/lorien/test_server/pull/24 ?

Comment 12 Fedora Update System 2021-08-25 15:57:57 UTC
FEDORA-2021-31ade01bae has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-31ade01bae

Comment 13 Miro Hrončok 2021-08-25 17:24:31 UTC
Requesting freeze exception, the package does not even install without the fix.

Comment 14 Fedora Update System 2021-08-25 18:37:29 UTC
FEDORA-2021-31ade01bae has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-31ade01bae`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-31ade01bae

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 15 Geoffrey Marr 2021-08-30 16:11:28 UTC
The decision to classify this bug as an "AcceptedFreezeException (Beta)" was made as it is a noticeable issue that cannot be fixed with an update.

Comment 16 Fedora Update System 2021-08-30 21:41:41 UTC
FEDORA-2021-31ade01bae has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.